Mixon 4 Platter wont change back to Vinyl mode

Mixon 4 (firmware 2118), iOS 11.0.3, Djay Pro 1.0.11

I think this may be hardware/firmware related but curious if anyone here on the forum has had issues with one of the platters on the Mixon 4 getting stuck in “jog” mode?

Hitting Shift + 25 (Vinyl Button) will toggle between the Vinyl Mode (Scratch) or Jog (Pitch bend).

For some reason my platter 1/3 is stuck on jog mode despite my attempts to turn it off.

I have gone so far as removing and reinstalling Djay Pro, reinstalling firmware, etc trying to check the obvious. I even tested with Djay 2 (have never used it before so I figured the MIDI mappings were good)…I had no luck.

Thoughts?

I neglected to update this one. Spoke to Reloop support and they confirmed it was a hardware issue. This controller was returned and replaced under warranty. No issues yet on the new device.

i just returned mine for same reason, no fix apparently, faulty controller…

So we can say it is not a widespread problem with the reloop mixon 4, but with an individual controller. Because I am heading to buy one of those very soon. And would like to assured that reloop works well with day pro.

Same problem

Solved!

…after going through everyone including Reloop authorised servicing folks locally in Mumbai who couldn’t figure the issue. Vinyl mode worked fine in their service centre but would stop working in my home setup.

Essentially, its a grounding issue. I had the output from my Reloop Mixon 4 going to my Marantz 8801 processor. Moment I disconnected the XLR or RCA outs from the controller, the vinyl mode started working. So the issue was with the processor.

I had 6-7 devices connected to the Marantz processor. Found the culprit in Step 1 itself. Moment I disconnected my Tata Sky Cable Set top box (including the HDMI cables), the problem was sorted!! Vinyl mode is working perfectly now

Short answer - There’s a grounding issue in the set-up. Find the culprit device and take it out.

I’ve also ordered some ground loop isolators from Amazon to see if that helps. That way I could keep my set-top box connected. But till then, I’ve taken it out of my set up.

Hope this helps!

i did a lot of research on the re loop site, forums, DJay site, Serato site, there is even videos of the jog problems on YouTube, before i sent mine back , apparently, only few were faulty , i was highly disappointed, it may have been fixed in a later update but i had a gig that week so i had to do something, i had a re-loop beat pad 1, and i really loved it, i was hoping this would be the ultimate upgrade, good luck, let me know how it goes, i may try to re-purchase one myself if all the kinks every get worked out

Could someone provide me the old firmware?
I installed the latest version but it was not perfect.