Mixon 8 Disconnection Issue

  • Device model (e.g. 2020 iPad Air 4th Gen): iPad Pro 5th Gen
  • Version of operating system (e.g. macOS 14.4.1): iPad OS 17.4.1
  • Version of djay (e.g. 5.1.2): 5.1.6
  • Hardware/controllers used (e.g. Reloop Mixon 8 Pro): Reloop Mixon 8 Pro v5039

Summary of the issue:
DJay Pro randomly disconnects from controller and reconnects. It is scary in live situations. Once it starts disconnecting it becomes frequent until I restart everything. Happens on the Reloop Mixon 8 Pro.

How to reproduce the issue:
It’s random but here’s a video: Reload bug - Google Drive

Hi @codebeast, this sounds like some kind of a hardware, connector or cable issue to me.

  1. Which USB socket are you using on the Mixon 8 (A, B or the USB-C socket)? Have you tried one of the other sockets?
  2. How exactly are you connecting the Mixon 8 Pro to your iPad?
    a. Direct USB-B to USB-C cable? If so, what brand of cable and have you tried a different cable?
    b. Direct USB-C to USB-C cable? If so, what brand of cable and have you tried a different cable?
    c. Through a USB-C hub or other adapters? If so, please share details about these.
  3. When connected, is your iPad charging normally or running off battery power?

Hi @Slak_Jaw

  1. I am connected to the USB C Port on the Mixon 8
  2. Direct USB-C to USB-C cable. I got a cable from Amazon and when it started happening I had to purchase a new one directly from Apple. The Apple one did not stop the issue
  3. When connected, it is charging. When it disconnects it stops charging and ones it reconnects charging resumes

Thanks for the additional info @codebeast. This is very likely a connection issue.

  1. If you feel confident that the Apple cable is fine, then I suspect it is the USB-C socket on your iPad or the USB-C socket on the Mixon 8.
  2. I recommend that you clean out the USB-C socket on your iPad first. I have personally seen these get clogged with dust resulting in intermittent connections.
  3. If that doesn’t solve the issue then I would try connecting to the USB-B socket on the Mixon 8 and direct to the iPad with a high quality USB-B to C cable (preferably with dual ferrite magnets on either end).
  4. You could also reach out to Reloop support to see if they have any reports of connection issues with their USB-C sockets.

Alright. Let me test these in the next few days. Thanks for the insights.

Sounds good. You’re welcome @codebeast.

@codebeast you could also take your iPad to an Apple store and have them check the USB-C socket for you. I actually had one of these fail on a fairly new iPad as well. Apple replaced it under warranty.

Yeah I suspect it’s the iPad too. Since I started this thread, I have been using my iPhone to DJ and no issues so far. I also remember have unstable connection when I connected the iPad to my mac a week ago.


This is really starting to point blame on the iPad IMO. Hopefully they can sort you out at the Apple store. I’m going to consider this topic solved for now, so I can focus on others. I will keep this open though, so please report back on how things turn out. Thanks!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.