Mixon 8 isn't working with djay AI

Just upgraded from the mixon 4 to the 8. I’ve been banging my head on the desk and can’t get it work with the ease as the 4.

I was able to update the firmware to v.4936 but still not able to read the controller itself. The crossfader does appear to work on display but nothing else. I’m using an '22 IPad Pro, and tried the macbook that I used for installing the firmware. Please help :frowning:


  1. Make sure your iPad is connected via a high quality USB-C to C cable to the USB-C socket on the back of the Mixon 8.
  2. Set the switch on the back of the unit to USB-C iOS (see below).
  3. Confirm that the iPad is charging when the Mixon 8 is on. If not try a different cable.
  4. Set the 4 switches for each channel on the top face of the Mixon 8 to USB-A. From the factory these are set to the middle position so you need to change them (see below)
  5. In djay, check Settings->MIDI Devices->MIDI DEVICES to confirm you see the Reloop Mixon 8 Pro listed.


Thank you so much! This was definitely an oversight, thank again!

1 Like

@XEFER you’re welcome. Glad that worked.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.