Moved to Tidal and beatpad 2 cross fader no longer works

Hi
Can anyone help me?
I have not been using my beatpad 2 set up since Spotify parted company, I have just subscribed to Tidal and tried to use the kit and cannot get the cross fader to work on the beatpad, any suggestions?
Thanks
Neil

Just to add, I am using iPad Pro with updated version of DJ pro (without additional subscription)
Thanks
Neil

First I would probably check the midi mapping and see if the crossfader is mapped accordingly. Another approach is the connection or the connection cable. I posted here in the forum some time ago my problems with the headphone output on my controller. Ultimately, it was the adapter that I used to connect the controller to the iPad. Maybe your problem can be solved with another cable.

Thank you Chris
Unfortunately I am not very experienced with the technical side, so not sure how to check the midi set up

I don’t believe that it is the cable, as I had no problems on the earlier version of DJ pro

I notice that this version has a little arrow by the side of the cross fader on the iPad that supports cross fading rather than toggling the cross fader itself, but as soon as connected to the beatpad 2, all the cross fader parts disappear and the physical cross fader does nothing except highlight the track

Pulling my hair out as doing a small charity gig in a few weeks and cannot play as yet after the upgrades

I have just tried the auto mix on the old Djay pro, and I can easily use the auto mix with cross fader using my saved music files, but cannot get either Tidal or Spotify tracks - on the new version of djay pro, I can get the Tidal tracks but not use the cross fader…… am I being stupid???

Hello there, and welcome to the forum. Can you advise if the cross fader works when you are using tracks loaded on the iPad and not on tidal?

It doesn’t seem to make a difference which tracks I use…

I have just realised that having been inactive for quite some time, I have not applied any firmware updates since purchasing the unit in 2017

I would appreciate some advice on what files should be updated and how to go about it, as I have never updated anything on the unit and hopefully this will resolve my issues

Any advice and any support in identifying the appropriate files and instructions to update would be greatly appreciated

I run the kit with the original iPad Pro with latest IOS and my computer is a MAC

Many Thanks in anticipation
Neil

Hello @Neilmacleod ,

Great seeing you posting here in the Community.

S/O to @Chris_R sharing his useful experience to help.

Just wanted to let you know I will be looking into this with the help of your Dev Team, so that if we have any specific suggestion for you I will post a follow-up in this thread.

In the meantime, I’m sure our awesome Community users will also post here with more information on their own similar experiences and suggestions.

Wishing you a great week ahead in the meantime!

Just to advise that I was given instructions from the technical team and was able to update the firmware accordingly, in addition, Andrew also helped me with options for running optimally, and to date everything seems to be working fine, very impressed by the support provided
Cheers
Neil

1 Like

Hey @Neilmacleod ,

Thanks for posting this awesome update and your super-kind words.

Glad to hear everything seems to be going smoothly after our Dev Team and Andrew helped. Don’t hesitate to reach back out if needed and enjoy mixing your favorite music with djay :slight_smile:

Cheers!