Multi output devices only work if there is no output selected for precuing

Hey, so I’m a streamer and I normally use a multi output device for my main output to allow me to have a virtual output linked to my stream software and then an output to my speakers at home, and then use my controller for precuing.

I booted up Djay today and tried to do my normal setup. Placing the multi output device as the master and my controller as precue resulted in no sound being outputted on any of the outputs (virtual sound card, speakers or headphone cue)
If I disabled pre cueing, the multi output device became fully functioning, but obviously no precuing is an untenable situation. I’d like to know whether this is a bug or a feature, and if its a bug if it is fixable

Edit: I’m using the latest version of Djay, iShowU audio capture as my virtual soundcard and a Numark Mixtrack Pro 2

Wondering if anyone has figured out a software solution for DJay Pro out to Multi-Output device + Cueing to another device?

Hi Marco Tiara,

can you send me an image of your setup? That would be very helpful in order to reproduce this.

Lukas E.

Hi Macro Tiara,

thank you for your follow up. I talked to a developer about your setup. The Multi-Output Device never sends the signal to both selected devices, it is not capable of doubling the signal.

But I think you dont need the aggregated device. You would need a virtual “Line Through” program which sends the signal to the broadcasting software.
We found this application, but also check if IshowU can directly get the signal:

If you have any questions or suggestions, or if you would like further information, please don’t hesitate to contact us. 

Lukas E.

Hey Macro Tiara,

I recreated your setup and the issue here is that Multi Output Devices can not be aggregated. 

That means we have to rethink your setup. 

I used another streaming software in order to check if the signal was getting transferred and it appeared that I was able to select the default audio device which gets the signal from the Built In Output. 

Can you check if you are able to select the Default PCM device in your broadcasting software as well?

Lukas E. 

There we go. An image of what my setup looks like on paper, what the audio midi setup looks like, the Djay settings that result in no sound and my OBS settings

Firstly, was my information detailed enough to reproduce the error? If you need me to i can make a video where I go through everything.

Secondly, I’m not sure what happened with 1.4.1 but the update has changed the nature of the problem.

If i set up a multi output device which outputs from my mixtrack pro II and IshowU audiocapture and then add my precuing as mixtrack pro II (channels 1 and 2) I can now get the master output from my speakers and precue with my headhphones. However for whatever reason this disables the output from the IshowU audio capture so the problem is still there.

Also another wierd problem that also happens now is if I have a multi output device set up which outputs audio from the built in output and IshowU audiocapture and then set the mixtrack pro II to precue, the master output comes out of the mixtrack pro II which is very wierd. This also disables the virtual soundcard in the process. Setting the precue back to “none” restores sound to the built in output and virtual soundcard.

So basically at the moment I can get either Master output/Virtual output OR Master output/pre cue by using a multi output device.

Do you have any suggestions for a workaround in the meantime while the bug is fixed?

My problem isn’t sending the signal- if I set the master output to IshowU or soundflower then my recording software picks that up just fine. The problem then becomes, how do I monitor that output, and the solution for 99% of people on mac is to make a multi output device for the virtual and real outputs. I’ve tested that on VDJ and mixx and it works perfectly, so I’m fairly sure the output not working when you try to precue is a problem with Djay.

I tried loopback, and it acts exactly the same my other virtual line outs. Weirdly though, placing loopback in a multi output device with my built in output and then using my mixtrack to precue works perfectly. Why that is is beyond me.

I would really prefer not to buy loopback ($100 is crazy!) but if it is a problem on my end then I guess I’ll just have to cop it. So I guess my question is, is the multi output device not working when precue is turned on a bug in the software or a problem on my end?

Also just want to say thank you for giving your time and effort to what is a problem probably affecting a negligible amount of people, that means a lot to me :slight_smile:

I’ve given up on the software solution, I’ve lost too much time for no gain. I’m now using a USB soundcard to output to my speakers and the line in on my mac and its working fine.

Thank you for your time

Sorry for the slow reply, I wanted to record a video tutorial of this for everyone to see. Here it is :slight_smile:

Hi Marco,

I’m having the exact same problem you’re describing here.

So, I’m also giving up, can you tell me more about your new setup with the USB soundcard?


Hi there!

I know why this is not working and how to fix it without another usb soundcard. Please see my post here and vote for it: