Need help setting up Numark Mixtrack Platinum FX

I am running the trial full version so I want to get this working before it ends so I can make my decision. When I connect my Numark Mixtrack Platinum FX I go into preference and select it from external on all decks and all options including cue. I have played around with the settings. putting ch 1-1 3-4 I can’t seem to get it to work properly. The cross fader does not match. Can’t seem to get it working to play through Numark Mixtrack Platinum FX correctly. I have speakers plugged into the Numark Mixtrack Platinum FX it works but the cross faders are opposite and don’t mute out when you put it all the way in either direction. Basically nothing is working properly.

Hi there

  1. Check under Settings>MIDI Devices that the Invert Crossfader toggle isn’t switched on…

  2. Check under Settings>Mixer>Crossfader Curve that it is set to default…shouldn’t make much of a difference but worth a try.

Is the sound still ‘full-on’ from the other deck when crossfading or is the sound ‘bleeding’ from the other deck?

If it’s ‘bleeding through’ then it could be the crossfader itself at fault. I had to get rid of my Mixtrack Platinum as I had the sound bleed issue.

Not saying that your mixer definitely has that issue but it’s one I had with that particular mixer.

I checked step 1 MIDI>option and invert was not selected. And step 2 was at default. I plugged everything back in. Now when I have one song playing it reads that it is on the correct side now but when I move the fader to the other side it just plays the same son louder. And if I have two songs on deck it plays opposite

Sorry fella, that’s me out! :smiley:

It’s going to have to be the Algoriddim Team who step in at this point…sorry… :frowning_face:

I tried though! :+1:t2:

1 Like

I guess I won’t be purchasing Djay pro. Looks like a great software too bad it isn’t working for me.

I got it to work. You need to keep it on internal

1 Like