Need Help: Unable to map Touch Sliders on NI Maschine Jam


I am primarily a Traktor user and sometimes Virtual Dj. In Virtual Dj I have no problem mapping my touch sliders on my controller. I am very happy to on the Djay Pro AI journey and all I have been able to do and map…however…

But doing a mapping and new to Djay Pro I was greatly enjoying how easy it was to map with buttons but when it came to my Sliders, goodness it was a futile situation that I tried every option but seemed only to give me touch extremes.

I figured since it was also made for the iPad there would be something easier to map out something dealing with touch but to no avail.

And one more item I have a knob that also functions when using Traktor when used to push or turn but could not find a way to map that. When as a button it was waay too sensitive when I mapped it to any kind of touch even when as a knob it would not act.

I am at a loss and have looked all over online to find anything. Perhaps I am missing something regarding the touch which is vital that I can use for volume and EQ.

For now I have had to resort to mapping buttons for up and down for volume since I cannot get the sliders to work.

all the best…

@Dj_Om-Amari unfortunately, I don’t have a Maschine Jam so I can’t test this out myself, but I do have a lot of experience MIDI mapping in Traktor and djay Pro AI.

  1. Could you please provide some screen shots of your current MIDI assignments for the various controls you’re having trouble with?
  2. For Push Encoders there are various options for the Type which when combined with the Speed setting should help you get to control you’re looking for. In my experience, you need to play around with the different options to get this working right. It seems to really depend on the hardware as well.
  3. The push button part of the encoder needs to be mapped separately as Type Button. You need to be careful not to accidentally rotate the encode when pressing it. Also, it’s possible that the Maschine Jam’s encoder is touch sensitive and sends a separate MIDI message when you simply touch without pressing it. So, you may have trouble separating the 3 MIDI commands in djay.

1 Like

Gracious gratitude for your reply. I will surely take note to these things and also add some screen shots of the issue I was having at least with the Touchstrips and the Button/knob on the Maschine Jam.

Ideally if I could map as it in in Traktor I am trying for the button knob, but know it may not be possible, as you mentioned yes it has 3 actions or more. When I am in Deck and mixing i can push to activate looping and twist the knob that changes “double down” to the left and “double up” to the right.

And when I am in the library browser I can push and twist it to scroll through the library or different branches.

But to stay on topic the main thing is the touch sliders and some functionality of the push/knob even if just to get the action for push to on/off loop and twist to increase decrease is fine.

Again, many great thanks for the feedback and will take a look and share screenshots if still encountering problems.

sidenote: I did take and use Djay Pro for my Dj set w/video set last night as a test but after an hour or so the separate screen option stopped and it just kept mirroring my laptop after working fine. I unplugged the hdmi…even restarted the software a few times and still no option of the button ever reappeared to do separate screen as it had the first time.

So I closed and just went back to regular dj’ing only in Traktor, esp since I know the flow and mapping much easier. But was still great as a test run setup to do.

@Dj_Om-Amari you’re welcome.

  1. Please note that Algoriddim djay Pro AI currently does not support modifiers like Traktor does in MIDI Mappings. So it’s not possible to have something like push & turn for the encoders. You can map the turn on its own and the push on its own, but you cannot then map a secondary action to push & turn combined. The only modifier currently in djay is the Shift button.
  2. You can, however, use the Duplicate feature in the MIDI Mapping to assign multiple MIDI commands to a single button, knob, encoder or fader.
  3. Regarding your screen mirror/video issue, I can share my experience on iPad which might help. Normally unplugging the HDMI cable from the iPad then plugging it back in will bring up the display message.
  4. If that doesn’t work, there is a switch in the main Settings>Show Video Output on External Display
1 Like

Gratitude on the issue on the External Display. I am using a Macbook Pro. I did all of that to no avail several times last night. Unplugging a few times and reconnecting the HDMI and also closing the program to start again a few times. Luckily it was the first hour so the bar was not busy yet and so asked the bartender to play music and switch me out while I tried to troubleshoot.

Each time, I would not get the message which I had no problem when setting up and tested earlier before starting at least three times and not an issue each time I plugged in I got the message asking or the icon. But during the set is when it just stopped and would only mirror my complete screen.

These screenshots, you have provided, I have looked and do not see a settings anywhere or icon, and have clicked on everything and gone through every setting under “Preferences.”

Is there something I am missing?

The window I have shows the Ableton Link but not the “Show Video Output on External Display” for toggle. I am using Dj Pro AI version 4.1.0 which I only downloaded last week from the app store and shows no updates needed.

I have attached what I see.

Again thanks so much.

djay pro - advanced no external only Ableton

here is the screenshot for the Mapping of what I have done so far.

The buttons are fine…the touchstrip is the main issue I am trying to resolve.

I chose “pickup” but it still left “speed” and “reaction” grayed out. I even tried it with “midi out” unchecked as well and no change.

So with this setting if I barely touch the “touchstrip” it just jumps to 100% and when I release it drops to “0”

@Dj_Om-Amari regarding the External Display issue:

  1. Here’s an article on how to properly setup an external display on MacOS:
  2. Sorry for the confusion regarding the settings on iOS, but as I mentioned, I don’t have a Mac. Based on this article the settings are quite different between iOS and MacOS.

Please let me know if that solves your issue.

@Dj_Om-Amari regarding your Touch Strip MIDI Mapping:

  1. Can you please expand the Control Type: and take a screen shot of the available options other than Fader/Knob?
  2. Can you please also expand the Options menu at the bottom and take a screen shot?


Thanks for everything I figured it out, mapping the Touchstrip Sliders, just before checking this mail!!!
I have been mapping the buttons on the controller for various settings today for some time.

Granted no LED feedback but hey does not matter I have the action…yaaaaaay!!!
Now I have buttons that were mapped for volume and other things I can use for other mappings now!

And today I thought instead try doing the “sliding action” from bottom to top and then selecting vs before I was just touching and it seemed to select too many instead of one.

This time I did the sliding action on the touchstrip faster and then as before selected the action for Mixer, Deck 1: Line Volume and as Fader/Knob. I did not have to choose “Pickup Mode” as it moved just as slow or fast as my finger would slide.

Very very happy to have this working and will finish mapping the touchstrips and tomorrow go to the bar early to test the video issue that happened and hopefully it works.

Again, many many great thanks for your time and help. Full of JOY!

I swear I had done this before but I guess like all tech sometimes you just have to think about doing it again a different way.

I still have not been able to find that

1 Like

Thanks for the article. I honestly thought that might be the issue and generally would have to switch off mirroring as when I have done Video projection using Qlab for other theatre events.

However when I plugged in Djay Pro last week, twice when I plugged it in, it actually overrode my home mirroring setup and worked so I did not think to switch it. When it went back to only mirroring only after about 75-80min into my set and unplugging and replugging and not getting the same thing I was not thinking fast enough to perhaps switch, as I was of the mindset that it worked why would it go out after more than an hour.

But yes, this right here is most likely the issue.

Again, much gratitude!!

1 Like

@Dj_Om-Amari you’re welcome! Glad that helped.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.