Need help with loading and editing a midi mapping

Hi Everyone

I got the Pro subscription a one week try and, unfortunately, have various problems, including a problem with MIDI mapping.

I have a XONE-K2, and found a mid map for it

I set the XONE up as required and plugged the XONE to the iPad, which recognised it. The controller did not work, so I loaded the midi map from the files app on the iPad but neither does it work, nor can I delete the map and start all over.

There is only one device “Network Session 1”, which I cannot delete. Rescanning for Midi devices does not bring anything up and there is no menu to edit the midi map.

The soundcard of the XONE is recognised and works. My question is how I can start over and create my own map with the controller (or get the map working)?

Deleting and re-installing the app did not work. There is also little help in the manual. The description there assumes that thing just work automagically, although not in my case :slight_smile:

Is there a way to delete a midi map?

(I use proper cables and the recommended adapters, since I was asked about the XONE K2 once, I am pretty sure that something was messed up when the midimap file was loaded.

Many thanks for any input

Olaf

Hi

“Network Session 1” Has nothing to do with what you are doing so ignore that.

You need to put one file in the IPad Djay directory to get your midi working and make it appear in the Djay midi settings where you can modify, duplicate & delete it.

This is how to get the midi file to where it should be on your IPad without using ITunes.

1: In Safari on the iPad, download this file.

download the file xonek2_t0mekk 20180829_final.djayMidiMapping

xonek2_t0mekk 20180829_final.djayMidiMapping

2: open the IPad files app
3: Goto downloads
4: Find the above file and hold your finger on it, then select move.
5: In the box that pops up find “on my iPad”, then find Djay and select it. Then at top right select “copy”. The midi file should now be in the Djay directory.
6: Connect your controller and it should now work without doing anything else. You can then make modifications if you want to in the midi settings where it should now be shown.

Hope this helps

*** if it doesn’t work. Goto file app, on my iPad, djay and make sure the downloaded midi file is there. It can’t work if it’s not!
**** If you use ITunes. The alternative method is to connect the IPad, go to file sharing, select Djay & copy the midi file into it. Both methods achieve exactly the same thing.

2 Likes

Dear @SteNight

  • thank you for responding to my question!

Unfortunately, the midi does not show up in the midi settings after I follow your routine.

Your step by step instructions were helpful. I first made the mistake of copying the html link … but then copied or saved the file with the extension .djayMidiMapping into the Djay folder and also tried the User Data Subfolder. Did not work.

When I click on the file, I am asked to install the midifile but when I say ok, nothing happens and the midi mapping also does not appear in the list in the MIDI menu.

Trying not to use a mapping but create one, I cannot see the XONE K2 device in the midi list of devices, so I assume that it does not recognise the controller. It did once and I was asked to configure it, as seen in the manual, but for some reason this did not take me anywhere.

I also tried different cables and adapters, to exclude this and while the controller is flashing and the app screen flashes, as if the controller is recognised, the mapping does not function (& the device does not appear in the menu)

I then tried another XONE K2, and I could now see the controller in the midi menu, all seemed fine, only that the mapping did not work. I then went through the setup of the controller, to check everything is correct (channel nr, no layers, … and boom - now also this controller no longer appears in the list, is again not visible. This suggests that the midi mapping file is fine, the problem is elsewhere.

This suggests that it is an issue with the XONE K2. Unfortunately, I could not find other mappings and even starting my own, I now don’t know how I can get back to Djay to recognise the controller :slight_smile:

Thanks for your input - it was helpful and kept my trying. My question is now how to reset the connection between the app and a controller?

Kind regards

Olaf