Neural Mix performance issue with master tempo

NOTE: Please use the search function above before posting to avoid creating duplicate topics.

  • Device model (e.g. 2020 iPad Air 4th Gen):
    Tested with MacBook Pro with M1 Pro / 16 GB RAM, iPhone 13 Pro Max, iPad M2, iPad Pro M4 1TB, PC with i9940X & 64GB RAM
  • Version of operating system (e.g. macOS 14.4.1): iOS 17.5.1, MacOS 14.5, Windows 10 H2
  • Version of djay (e.g. 5.1.2): 5.2, first noticed with 5.0
  • Hardware/controllers used (e.g. Reloop Mixon 8 Pro): without controller, with FLX4, with Rane One

Summary of the issue:
Neural Mix lags if master tempo is enabled (and in use = pitch +/-).
Unmuting drums need approx. 1 beat to be heard again instead of being back immediately.

How to reproduce the issue:
Load 2 tracks.
Enable master tempo.
Change the tempo of both tracks, so that master tempo has something to do (eg. +/- x %).
Play both tracks.
Mute the drums with Neural Mix on one deck on beat 4 and unmute on next beat (usually beat 1).
Usually you should hear the drums again on beat 1, but you won’t.
The waveform will show that the drums are back, but you won’t hear them.
You hear them on the next beat (beat 2).

Currently this only works if you disable master tempo.
If master tempo is off and you try this it will work and Neural Mix won’t lag.

Hi @Saiboter, thanks for sharing the details about your setup and the issue. To help us to replicate this issue and troubleshoot it with you, can you please try to capture a video of the issue, upload it to your Google Drive/Dropbox, enable sharing permissions, then share a link to the video here? Thanks!

Here you go, the kick on beat 1 is missing, because of a lag:

With tempo fader on 0 % (it’s the same with master tempo off) you can hear the kick on beat 1 = no lag:

Thanks for the videos @Saiboter. This is super helpful and clearly illustrates the issue. I have forwarded this to the engineering team to see if they can reproduce the issue and offer any suggestions. I’ll report back here when I have news. Thanks!