New to Djay and DJ'ing

I’ve downloaded the trial for Djay and I had a few questions as I’m brand new to this!

I have two songs with matching bpm, I want the second deck to start playing near the end of the track on the first deck. I keep trying by pressing play, but I miss out the beat and it all goes horrible. I’m gradually moving the crossfade over to merge it into the second track too.

Any help would be awesome.

I would urge you to avoid the sync button while you learn the basics. I try to only use the sync button to cover up for a mistake I make while mixing. But I’m an old vinyl guy, so I don’t know maybe I think it makes the whole thing a little too easy. This may just be a old-purist-in-a-new-medium preference thing. But Ryan above is right, the sync button would save you, but won’t even really work that well unless you make sure that the yellow beat line is aligned to a down beat of our tracks song (you can move it to match up).

There’s no way (that I know of) to make the currently playing track’s end point “hook” the other deck’s start points and begin. It’s a feature I’ve thought about too. But I ultimately landed on the side of, yeah it would be cool but automating this process any more and you kind of begin to lose the fun. Again, purists would probably suggest you just instead learn how to actually start a track and get it matched up quickly using the waveform visuals. Hell, they’d say that you should be able to get the next track playing, beat-matched and phrase matched without looking at the visuals at all, just listening to the cue. Oh yeah, the cue…

It sounds like you’re just beginning. So, to give you a tip directly regarding your question: to avoid the cacophony of two songs playing at once, match the waveforms up visually (by hitting play, then tapping those plus and minus buttons until your song is matched up) and THEN begin bringing it in to the mix. Also, just because I don’t know what you know (not meaning to insult you or anything) but the reason you see DJs put headphones on is because they can preview the mix (the “cue”) before presenting it to the audience (the “program”). A vinyl dj (with no fancy things like key-lock or sync buttons) would listen to the next record they’re going to mix in to, get it all beat-matched, then take their headphones off and start mixing it in while listening to the program (with the audience), and make any adjustments needed on-the-fly. Of course in order to get this same experience, you would need a splitter cable as Ryan mentioned, or get a controller that has an audio interface in it (like the Numark Mixtrack Pro II) that can provide both a program out and a headphone cue out. But honestly, its possible to use this software without hearing a cue. It just takes practice. Do yourself a favor and learn all the deck keyboard shortcuts!

Use the pitch-bend buttons (if you have a controller, you can also use your jogwheels to do this) to “nudge” the incoming song forwards or backwards so that the beats line up with those from the currently playing song. Then, once it’s lined up, move the crossfader over. You can use a loop to get the intro beatmatched before the end of the other song, and then release it once you bring the new song in.

If you have a soundcard or splitter cable, you can listen to the new song in your headphones while the other one is still playing.

Or you can go into waveform view and do it visually.

Or you can just press the Sync button, although the phrasing may be off by a beat if you do this.

There’s kind of a way to make the end point of one track automatically start the other deck’s track from the start point - in the preferences, under Automix, you can check “Use start and end point if available”. However, there’s a lag (it doesn’t really pair the two cue points together), and you can’t override the movement of the crossfader.

I normally use the waveforms and pitchbend, but the recent update appears to have made a change to the waveforms that makes beatmatching way more difficult than it used to be. (…) Is this happening on your computer too?

If you’ve manually adjusted the BPM (assuming the analysis is correct) so that both songs are the same and pitchbend the new song so that the beatgrids line up, or if you press the Sync button, the two songs should stay beatmatched during your transition.

If your gaming soundcard works, you could send the cue signal through your computer’s soundcard (plug your headphones directly into your computer’s headphone jack) and have the main speaker audio go through your Astro mixamp.

If the external soundcard isn’t working and you don’t have a DJ splitter cable, you’ll only be able to have one output signal go to both your headphones and the speakers.

If you’re still getting started, don’t worry about beatmatching by ear using two audio signals. Just use the waveforms or Sync.

Yes, before the last update, the beatgrids of two songs that were adjusted to the same BPM (even if they weren’t originally the same) would be perfectly aligned. Now they’re not.

I don’t get why this was changed during the update. For those of us who use the waveform to beatmatch, the software is basically unusable now.

Thanks for the advice. I’m so new to this its like learning a new language.

I’ve been matching the waveforms up since I started earlier. I just cant seem to get the second deck to play on the beat. It ends up going off track while cross fading it at the same time.

At the moment I just wanted something to quickly match two songs as opposed to cross fading them via built in software on audio players. I’m going to a charity/community event thing tomorrow and the music is literally just playing from one track to another. I wanted to see if I could do anything to “better it” as a family friend is involved and I’d like to sort it out. Perhaps there is an easier way?

Yeah, I gathered about the cueing with the headphones. I’ve not got any fancy equipment, I’m just running on my macbook pro. The only tec thing I have was a astro USB mixamp (For PS3/XBOX/PC gaming) sadly the usb pads on the PCB have come off and I’m stuck running right through the 3.5mm jack

Can I not play audio out through the speakers on the macbook and into my headphones from the 3.5 jack?

Sorry about the bombardment of questions etc. I’m tired and clueless! Haha

Thats a pain in the backside. I dislike the auto cross fade because I like to take it to just 80% with a faintness of the first track playing in the background.

I think im getting the same thing.

If both songs are 124.0 BPM the little bars that show the beat should in theory be perfectly aligned?

Mine aren’t if thats what you’re asking?