[new user] 3 beat skip with seek function

Hey there,

New user coming from Traktor and enjoying so far the Mixtour, all but one significant problem I am encountering and can’t solve.

Using the seek function (Holding T and using the browse knob), it jumps in the tracks every 3 beats.
Even though I selected 4 beats (or 1 or 8) on Djay pro 5.
Can you set it up differently ? I looked on the settings and on the midi mapping.

Tracks and loops being (mainly) on a 4 beat basis, skipping 3 beats seems like a nonsense to me and it is not acting like the soft does.

This would make for me this controller perfect and is the only thing holding me back from letting traktor pro 3 and go Djay pro.

Thanks if you have a way to solve this !


Hi @Tadar, welcome to the community. That sounds like unusual behavior. I used to have a Reloop Mixtour and the beatjump worked fine.

  1. Have you modified the “built-in” MIDI Mapping at all?
  2. Can you please share a screen shot of the MIDI assignment for “Holding T and Turning the Browse Knob” and ensure that the Advanced Control Configuration menu is expanded and visible?
  3. My initial guess is that you need to adjust the Type to one of the other options and potentially the Speed to get the desire 4 beat beatjump length.
  4. In my personal experience, it usually works better to MIDI map Skip Backward and Skip Forward to two buttons for beatjumping.
  5. Please also share some more information about your setup: computer details, OS version and djay version.
1 Like

That’s how I have mine set up

1 Like


Thank you for your reply,
I did not change the MIDI Mapping but tried things and indeed I found the solution by changing the speed, it is as a standard set to 300%, hence the x3 factor.
I changed it to 100% and it works fine.

The only thing is that you need to have a subscription to change MIDI mapping (which I will gladly take to support the dev), but it should be set to 100% as a standard for this functionality.

Setup info are : MacBook pro M2 Sonoma 14.2, and djay 5.0.2.

So question is answered thank you for your swift replies, looking forward to get into this community,

Glad to hear that fixed it. Thanks for the feedback!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.