"No results" displayed in search

Just began setting up with my library on an external hard drive. I have 1.5 tb of music to load, and no matter what I type in to the search box under “my Mac,” it displays texts that says “no results.” An I doing something wrong? When I load a song directly from my Mac, it finds it right away.

Lukas: I have a regular APFS mounted volume (my internal mac drive) on Catalina.  Search My Files always returns No Results. 

looking at this as well, does not seem to search ext folders from an internal drive either. I have a 1tb in place of my dvd drive and a ssd as opperating, itunes library works but many of tracks are not in itunes

Hey Jesmen Lucas,

thank you for your post. 

Which folder of the external hard drive did you selected as “My Mac”-folder?

Cheers,
Lukas E.

Hi Stuart,

I am very sorry to hear that.

Can you record an exemplary video and send it to us via support@algoriddim.com?

If you have any questions or suggestions, or if you would like further information, please don’t hesitate to contact us. 

Hi there,

be assured we are working on the issue and will provide a solution soon.

If you have any questions or suggestions, or if you would like further information, please don’t hesitate to contact us. 

Hi guys,

at the moment NTFS and FAT32 formated hard drives are not searchable in that manner.
I want to inform you that we are working on this problem.

Thank you for your patience.

Cheers,
Lukas E.

I have tried this and I can’t get search to work with ANY folders added from an external Hard Drive, only ones on the internal drive. Is this actually what happens? If so, what a useless piece of software!

It seems to be that the search will only work with FAT32 formatted external drives - I can’t get any of my NTFS drives to show up in the search. Anything saved on an external FAT32 or my internal Mac drive show up in the search. What a pain.

I sent a video but not had a response?

I added a few different ones that are on the drive. One is called “my music” and has many sub-folders with artist names and then folder of album names in those. The music is displayed when locating manually looking through the drive on the “my mac” area but im getting this problem when searching

Search with my local folders doesn’t workt. Who knows what to do?

Hello Lukas,

do you know how many users experience problems with the my mac external haddrive search subfolder issue?

You must know that it is not working.
Adding a Music directory via mymac that has subfolders works.

Searching each folder works.

Search does NOT include subfolders.

What do you do about this? There is no public solution or statement for this issue. Its always the support E-Mail and silence about this.

So please tell me what is the solution?

Please solve this! Is there any news regarding repair of the explorer search function??