No sound output to soundcard

Using Djay on an iPad Air 4 together with an Electrix ebox 44 soundcard. It was working fine before, but ran into an issue today.

There is no sound going to the soundcard, though i have selected the available outputs.

I have checked other apps like DJ Player Pro (sounds come through as expected) and Ableton Note (comes through the soundcard as well).

I can see the DVS input signal in Djay though, but no output, though it’s selected.

Internal mixing seems to work, only not with the external soundcard.

What can I do to fix this?

I have also tried the mac version of Djay, this seems to be working, just the iPad app not.

@Kikeon is anything else connected to the iPad like a USB hub, HDMI cables, etc.?
Is the iPad connected to power and actively charging?
Have you tried turning Bluetooth off on the iPad?

1 Like

Thanks for your suggestions! The iPad is connected to a USB hub/adapter (usb-c to usb-a connections) The only thing connected right now is the soundcard.
As suggested I have tried turning off bluetooth as well, but didn’t do the trick.
The thing is, other apps, like DJ Player and Ableton Note seem to work fine, so I expect the problem somewhere between Djay and the soundcard.

You’re welcome. In the Audio Device Setup, under Mixer Mode, try Internal.

Internal and ‘Output to iPad Speaker’ gives me the audio through the ipad speaker, as expected. But when i try to select the main output to the Ebox, still no sound.

Hmmm… strange. Try Reset to Defaults at the bottom of the Audio Device Setup.

If that doesn’t work, unplug everything and restart the iPad.

Sometimes the order you connect things matters on iOS so try the following.

  1. with everything unplugged, launch djay
  2. plug in your USB hub
  3. connect power to the iPad and confirm that it’s charging
  4. connect the soundcard to the hub

Also have you recently updated your iOS or djay version? If so this could be a new bug. If not, I suggest backing up your iPad to your Mac, then updating both.

I’m using iPadOS 16.3 and Djay version 4.1.5, so both latest versions. I did not have time to dj the past month, so not sure up until which versions it was still working.

I tried resetting to defaults and restarting the iPad before. I have just restarted it again and connected as you suggested, but still nothing.

@Slak_Jaw big thanks for the suggestions. I will try again tomorrow.

You’re welcome! Sorry I couldn’t help. Sounds like it could be a new bug to me. I suggest you send an official report to Algoriddim via the djay app. Go to Settings and scroll down to Contact Support. This will provide them with all the details of your setup. Cut and paste the important stuff from this discussion and hopefully they’ll get back to you soon.

1 Like

Be sure to try out the fiddling going on (later) in this thread…


Hey @Kikeon ,

Thank you for posting this here in the Community.

Just writing to reassure you we have received your email and will be following up to help you as soon as possible. For now, thank you for the useful information you have shared, as it will make testing this on our end easier.

Also thank you @Slak_Jaw and @Mister_Tuur for your helpful input. Cheers!

1 Like

I have had this same issue with a behringer external soundcard. the only solution i have found is to reboot ipad. i do not have this issue with scarlett 2i4.

unfortunately a reboot didn’t work here, but thanks for your suggestion.