Numark Mixtrack Platnium FX - DJ Pro AI - Midi Mapping not working

Hi there and welcome to the community.

When you go to the MIDI mapping section, have you tried pressing the button on the controller to see first that it registers? once you press the button on the controller it should take you to its MIDI mapping.

There is a recent thread where articles have been posted showing you exactly how to map controllers. I will try and find it and post the link here.

Thanks for the quick follow up! Sorry but which button are you referring to?

Hi there. I am talking about the butten you want to map

Ah - I will try this . Please let me know if you find that article ty!

Will do you seem to be posting multiple posts of the same reply
Not sure if it’s a bug on the device you are using

Here you go

Hello @RP732 ,

Thanks for posting about this here in the Community.

Did the articles @Djdash share help you with mapping your Numark device?

If you’re still in the process, can you please confirm if you’re having issues with mapping specific buttons or, rather, the process as a whole?

Thanks, I’ll be on the lookout for your reply!

Hello! I was under the impression that the controller would work perfectly
when plugged into my computer and running the software. The basics work but
when it comes to some of the functionality on the controller like filter
knobs, EQ , Quick launch effects. I didnt know if there was a download
needed to have the controller running with all functionality. When I plug
it into serato, the controller and all the functions run smoothly.

Please advise, thanks!

Hi there. For some strange reason your post is replicated multiple times. Ok each software has its own way of mapping a controller. Most of the functions should work out the box however, in some cases you have to map them out. I have not used Djay on windows but I will assume it’s the same. Do you have the pro subscription?

Hello! Sorry about that not sure what’s causing the multiple responses. I am using the DJay AI pro on my MacBook Pro. It seems I will have to map out most of the features myself but even when going to map each one, not all the features are available on the pro software I have. I was hoping it would all be automatic.

Hello @RP732 ,

Thanks for the info you have shared so far regarding your experience. It’s been useful!

Would you mind also sharing which exact features/functionalities/buttons are not available on your djay Pro AI app when you’re trying to map your controller according to the steps @Djdash shared here?

The Numark Mixtrack Platinum FX is part of our list of natively supported controllers for Mac (click here for the full list), but I could pass your feedback regarding the missing features to our Dev Team for further consideration.

Wishing you a nice day in the meantime!

1 Like

Thanks for the follow up! I attached a photo of the buttons that don’t seem to be working unfortunately - also when I plug in the controller the jog wheel bpm numbers sometimes just keep running and increasing vs staying at the number that the bpm that the song should be. I appreciate you looking into this and or any further suggestions. Let me know if you need any other info from me , thanks all!

1 Like

I also tried to map each one myself per the suggestions but when I press each button I didn’t see an option to map it too, only the basic buttons on most controllers

Hi guyz

I have a similar issue the screenshot shared above for fx paddles do not work. Please can you advise on the manual mapping for each of those controls under the fx section

Please advise on the manual mapping for each of the control in this screenshot. That’s the only problem I have at the moment

Paddles are working fine for me but it seems that FX buttons are not remappable…

Thanks for your feedback… can you share the mapping for the paddles to work.

It works natively for me (ipad version).

Any workaround that you are currently using for the fx ?

no… nothing… straight out of the box…

I assume that you tried to move the dry/wet knob ?
Sometimes it can remain at dry position in software at start up.