Numark N4 mapping issues with djay pro

I have recently bought the djay pro and a Numark n4 controller. I was a little dissapointed that it didnt work straight away but i got to work on mapping the controller. After i had mapped it I played around with it for a bit I shut down djay and disconnected the controller. A little later on i came back to use the controller again and found that some of the buttons had un-mapped themselves. I remapped the buttons that had undone themselves and found that the buttons were still in the list from earlier but no i have to duplicate the key. Has anyone else found this from mapping their controller with djay pro?
thanks in advance

Same here, it would be great if the Numark N4 is supported. Problem solved for a lot of people! and I strongly prefer Djay above both Serato and Virtual DJ.

I haven’t tried that controller yet. If the jogwheels are touch sensitive then there should be two controls when you press down and move the jogwheels in the MIDI configuration window.

* Map the button to “Scratching Mode”
* Map the CC control to “Scratch”

There was a similar issue with the Native Instruments Kontrol S2, and the workaround was to go into the code and make a change.

See this thread - maybe you can do something similar. Still, it would be good to have an official patch to fix this issue for everyone.…

Yes, the exact same thing happened to me…and I don’t feel like fixing it every time. It actually makes it impossible to use!

can you guys give me information on how to map my jog wheels… I’m using a Numark 4trak… similar to the N4 and NS6 but designed for traktor and not serato… Thanks

Can you export a .tsi file so the the mapping configuration get saved, and then import the .tsi file back in when you start everything back up?

I have tried that, but unfortunately this doesn’t work for the 4Trak :confused: Any other suggestions? Thanks in advance.

I fixed it myself. Maybe not 100% perfect, but working good enough. You can download my mapping here: