Numark Scratch DVS suddenly not working on iOS and OS

Since yesterday my DVS set-up doesn’t work aymore. I use Algoriddim x Numark Scratch, but software doesn’t automatically detect hardware, on MacOS as well as iOS.

Maybe it helps if you disconnect your iPhone/iPad and reconnect again?

Been having similar issues with connecting to my setup. The soundcards and the channels seems to be connected and recognised, but dvs does not work. Then I check, and check again. And suddenly it works again, but nothing is really changed. Can’t yet really put my finger on it, but disconnecting and reconnecting my iPad seems to do the trick.

Appreciate the advice! Did not work though…


  1. I would perform a Forced Restart of your iPad and reboot of your Mac.
  2. Then please disconnect everything and start from scratching using the instructions below:

Hi @MRKJCBS, just following up to see if my suggestion above solved your issue? Thanks!

Tried it, didn’t work :frowning:

Hi @MRKJCBS, thanks for the update.

  1. Has anything changed in your setup between when it was working and stopped working (new OS version, new djay Pro version, new firmware, different cables, etc.)?
  2. Please provide screen shots of how your DVS system is connected to your macOS and iOS devices showing all cables?
  3. What version of djay Pro are you using?
  4. Do you have an active paid subscription to djay Pro?
  5. What macOS and iOS versions are you using?

Why we need to VOTE on this topic/bug? :smiley: anyway, I have had the similar issues with my setup, I just realized that, if disconnect the USB B from mixer, then reconnect it, the magic :magic_wand: will happen. Give a try!

@DJ-Z you do not need to Vote. Voting in the Hardware category is typically used when there is a request to add support for new hardware not for bugs or issues.

Tried it. Magic did not work.

  1. iOS has had an update, OSX not.
  2. Cannot make a screenshot at the moment, the bug is in NuMark Scratch I am afraid.
  3. 5.03
  4. Yes!
  5. MacOS 10.15.7 - iPad iOS 17.2

Thanks in advance for your thoughts.

You said the bug is in the Numark Scratch. What makes you say that? Have you tried updating the Numark Scratch firmware?

There is none, it’s supposed to be plug and play, which it is not anymore. Cables are good, devices work. So unless you guys know of a bug in Algoriddim, it must be the mixer.

Okay thanks for the update @MRKJCBS. I can’t think of anything else to suggest, but I’ve forwarded this to the engineering team to see if they have any ideas before we conclude that it’s an issue with your mixer. I’ll report back here when I have more info. Thanks.

Hi @MRKJCBS, the engineering team was unable to reproduce this issue. Could you please share screenshots of your DVS settings? It would also be interesting to see if there is any input in the DVS settings. Thanks!

Hi again @MRKJCBS, just following up on my message from a week ago. Thanks.

Hi @Slak_Jaw I sent the screenshots via e-mail to staff 10 days ago. Do you want them here too?

Hi @MRKJCBS, if you’re being helped by someone via email, then there’s no need to share them here and I can close this topic.

Not being helped but go ahead.

@MRKJCBS, in that case, please share the screenshots here and I’ll try to forward them to the engineering team before I leave for vacation. Thanks.