One deck won't play?

Last night in the middle of a session one deck wouldn’t play. I could load tunes onto it, but when I pressed play the record icon just flashed but wouldn’t play. I solved it by disconnecting, cutting the power and reloading it, but obviously in the middle of a set in front of lots of people that is unacceptable. It’s working now, but I obviously can’t have that happening again… I’m a pro DJ and if that happens again I’l be forced to find another system… any ideas? Its DJ Pro, Reloop beat pad and macbook pro.

This happened to me ONCE as well. Loaded a track and it would not play. Reload it and it works fine.

iTunes playlist.

Happens right now ! Track loaded - Waveform ok. - Button Play blinking
not playing

Have you been playing from iTunes or Spotify? Can you try loading the tracks you’ve been playing before to see if it happens again?
Thanks a lot for the support.

Jeff, would you join our Beta-tester program? That would be very helpful to get more information about your problem and how to fix it. Take a look here:
https://rink.hockeyapp.net/recruit/82922abd9ecb44368c864260281e0507

I tried reloading the same song and others, none worked… they loaded but when I pressed play the vinyl icon just flashed… (as though I was selecting and deselecting it with the crossfader - except I wasn’t). I use it only with Itunes, not with spotify. It was fine after I rebooted the whole system (last resort), but that took a bit of time which was rather embarrassing. I hope this isn’t going to happen again because otherwise I’m very happy with the whole set up (apart from headphone volume maybe which could be more in a loud club).

I have responded. The good news is that there isn’t a flood of people saying “me too”… which is a good sign!