One more BIG BUG after big updates 🤯

So, I want to report about this BUG situation last mount I have a few gigs and one of them was ONIX warm up support and I was restrained to do anything with the set up ( pioneer ddj sb3 + iPad Pro M1 + usb - c apple connector ) on the stage in the beginning of the show.
After this lasts updates if I want to switch between hardware mode on / of the connection is lose and I have to restart Djay app in any case even the iPad. The controller is goes out and have to reconnect.
I feel a very huge LAAAAG.
I can’t understand we pay for the previous version Djay pro 2 and you are close it after that you told us Your customers we will give you Djay pro 3 with subscription :eyes: .
I feel deceived, robbed and disappointed after this years of support your project.
Can you imagine what kind of stress is that when you are on the stage and what’s happened of my reputation on.
I want to be compensated.
Please keep the hard work hard and listen to your customers really.


Hi @Digital_Jedi,

Thanks for reaching out and sorry to hear about your experience at your show. I can understand how frustrating that would be!

From what you’ve described, it sounds like when you switched hardware mode on/off in djay, this is when the problem started. Could you please tell me if this is reproducible every time you switch the hardware mode on/off, or was this the only time it happened?

When you say the connection was lost in this moment, and you had to restart your iPad and djay, as well as reconnect your controller, could you please tell me if djay crashed completely (i.e., djay completely shut down)? Or did everything seem to freeze up, forcing you to close djay, restart your iPad, and reconnect your controller?

Thanks in advance for the additional information. We’d like to help troubleshoot to figure out what went wrong here if possible. Sorry again for your experience - can definitely understand how stressful that must have been.

Hi, the app is not crashing just freezing and lose connection between iPad and controller. And not every time when I connect the setup everything is connected.

Thanks for the additional information. I’ve just tried to reproduce this behavior, but haven’t been able to. For this reason, if you’re able to reproduce the freezing behavior, could you please get a video of the issue occurring and drop it here? Just let me know when you’ve done so, and then I can further troubleshoot this with you.

Thanks in advance!

I still have this BIG PROBLEM last night I have gig and have to restart and close/open the app few times before it’s working properly :eyes::thinking: after last news for upcoming new software and new integration and functionality like new flex 4 and Stems from serato.
You have to gays to think carefully.
Please listen your customers and improve functionality of the app we all give you a feedback from our experience.

Sorry to hear this problem is still occurring since our previous messages! I will pass the information along to our Dev Team to have them re-check this setup again. We would need to be able to reproduce the issue in order to find a solution, and we were not able to do so previously. In addition, we did not receive a video of the issue from you per the previous request to help us in reproducing or resolving the problem.

So that we can get to the bottom of this, could you please share if anything has changed in your current setup? For example:

  1. Are you still using the same hardware?
  2. Have you updated your djay Pro AI version, and if so, what version are you using?
  3. What iOS version are you using?
  4. Please share if the same behavior is happening as before, or is anything different now with the current freezing behavior?

I’m assuming you’ve already done so, but if you haven’t yet, could you please try using different cables/adapters in your setup when connecting your hardware, as this can be part of the problem in situations where devices lose connection with one another. Please confirm whether you’ve already tried this troubleshooting step as well so we can rule out cables/adapters as part of the problem.

Thanks and I look forward to your reply!

1 Like

Hi Emily, I’m not changing anything the same setup (iPad Pro M1 iOS 15.1 last version of Djay Pro AI 4.0.12 Pioneer DDJ SB3 original cables USB - C to Digital AV from Apple store).
The issue is when connect the setup sometimes a lot in few mounts not connection at all or if I reconnect not responding and Pioneer not blinking. I had to restart the app and iPad to take working. Not feel safety, really.

Thanks for the additional information. I’ve gone ahead and had our technical team take a look into this with our equipment here. They’ve shared that we are still not able to reproduce the behavior you’ve described with our devices, but they did share some additional information that could be helpful in troubleshooting your setup.

One possibility is that this could be a hardware issue related to the USB port in the back of the SB3 possibly being a little loose and therefore having some wiggle to it when plugging in cables. Do you notice this at all?

If so, this could result in the controller disconnecting randomly if the cable is either:
A) Not fully plugged in properly.
B) It can be plugged in, but when moved a little due to the wiggle room it now has, the connection drops or the proper pins aren’t touching anymore, both of which causes the controller to drop out and reconnect itself.

A second possibility is that there could be an issue with the power source. Could you tell me a little more about how you’ve got your controller and iPad connected to power sources when this happens? It would be helpful for us to continue troubleshooting if you could share a photo or video of the connections as well.

I hope this information is helpful! Looking forward to your reply.

1 Like