OSStatus error -43

Anyone know the problem for OSStatus error -43 cannot load rack error…? For ipad

This reply was created from a merged topic originally titled
Massive library problems with DJay 2 and iPad 4.

This appears to be an iTunes problem to me when I explain my findings, but now I cannot use DJay 2 for any event until it is fully reliable again.

I used djay2 all day on Friday without a glitch.

I arrived home and plugged iPad into my iMac to resync and charge a little.

I turned on iMac screen to see that iTunes had updated to version 11.1.1 (11)

I arrived at the venue to play music on Friday evening only to find that the last 800+ songs that I had added to my library were not playable and there was no way to tell without first trying to play them.

The on screen error reads “Could not load track” “The operation couldn’t be completed. (OSStatus error -43.)”


Anyway, all was not lost but a frustrating evening it was.

I tried to play some of the “damaged” tracks in the stock Music app and the app could also not play them but did at least remove the songs from the library. Applying this method to each playlist, removing the songs unplayable automatically, removed around 840 songs and what I was left with was basically the music I had on my device BEFORE I updated to the Gold Master version of iOS 7.0

Is this an Apple problem? Time for me to wipe my iPad and start again or should I wait and see what happens? I have removed all music and started putting it back on playlist-by-playlist and again the problem has started to happen, with different tracks this time.

Which iOS version do you have? Also, which app - djay or vjay?

Please try re-syncing your songs to your iPad/iPhone. If you’re using iTunes Match or if the songs were purchased in the iTunes Store, try deleting and re-downloading the songs thru the Music app.

This reply was created from a merged topic originally titled
Djay 2 (OSStatus error -43.).

When i load a song from my library it can not load The track into the player for djay 2. But The Same song can work perfectly in The music app.
Everything is updated with The latest versions

Could not load track
The opperation couldn’t be completed.
(OSStatus error -43.)

This reply was created from a merged topic originally titled
Tracks not playing on iPad iDJ2.

I have been using my App perfectly for months out DJ’ing and this week it suddenly stopped working and would not load tracks and this message appeared OSStatus error - 43. What can I do as this ruined a set and caused me nightmares on the night! … Please reply ASAP

This reply was created from a merged topic originally titled
DJay 2 Track Cueing / Loading Problem..

Recently downloaded DJay 2 onto my iPad 2 while it was still running iOS 6 and everything was running perfectly… Even synch to my iDJ Pro worked without any flaw…

Then I upgraded to iOS 7… Now about every 3rd track I try to load gives me an error… (OSSystem error -43)… It is doing the same thing on DJay 1 now as well…

This is a Major Issue. Anyone else having a trouble loading tracks… Any advice.


Had same problem, try to pik these songs from the cloud again, even though they are already on your ipad. When it is downloaded new, it works in djay2 again…


I have the ipad3 and running djay2. Getting the error - “Could not load track” "The operation couldn’t be completed. (OSStatus error -43.)


This is such a problem for me right now. Not liking this OSStatus error -43. Sure making algoriddim and apple look like donkey’s right in front of a whole gang of people. Just bought the headphone splitter and now this. Guess I’ll be playing New Years music through my music app like a chump. Thanks a lot DJ for ruining my party. I kept telling them that it should just work, I switched to Mac so I didn’t have to work around or tweak my computer. Extremely disappointed.

Help I’m having the same error code? How can we fix this?


I had the same issue following sync errors on Itunes. My tracks were not readable in Djay nor Itunes.
To solve it, i had to follow the apple procedure :

  • turn off music, videos & photos sync then apply
  • turn them on again & apply
    It may take time depending your data size but it worked for me.
    Hopefully, Spotify saved my new year party.

You can solve this error problem on the fly by switching to your Music app on iPad, deleting the track, then re-downloading it. Once it’s back on the hardware it will reappear in djay as a playable cut.

Got this problem can anyone help???


same prob for me but i think it an iTunes issue as started when i tried to manually move some songs over from my mac onto the iPad. the sync kept hanging on 'preparing to sync. all my iTunes purchased songs load fine but not my ripped tracks. got to get to bottom of this!!

Trying to play via iTunes it seams that tracks are not where they should be as it comes up with a red circle (like the iCloud download circle) bur purchased play fine

This is happening to me as well with purchased songs from iTunes

Now its giving me the -54 error too!

Still getting this…help me, help you

version 1.1