Pasted song detection problem

I’ve exported loop from dm1 as audiocopy then pasted into deck in djay2. The waveform is missing, djay loads waveform from previously recording - I guess, but plays pasted audio. Wrong waveform is displayed above the deck and in “big waveform” mode (instead of deck view). The BPM is 0 (but loop has easy to recognize 4/4 kicks). This problem is repeatable every time djay is closed and launched again. Total time of pasted audio is displayed ok. Loop plays/scratches fine.

Hi Artur,

Thank you for contacting us.

  • Which djay version do you have?
  • Which iOS version is running on it?
  • Does this also happen when you copy a djay recording and paste it onto a deck?
  • Do you have any other apps that support audio copy&paste?

OK thanks, I’ll look into this.

Do you by any chance know the file format the other apps are using?

Oh ok, glad to hear that it’s working again. Please keep us posted.


  • iPad djay 2.6.1

  • iOS 7.1.2, iPad 4th generation, 32GB, wifi only

  • no, internal djay recordings loads fine, the waveform is displayed properly, bpm also, audio pasted from clippord has empty waveform with random artifacts, 0 bpm but plays and scratches fine.

  • i’ve tried many apps - DM1, iElectribe, Cubasis, copied and pasted audio into djay2 behaves the same way every time. For the same copied audio Cubasis is able to paste it properly - waveform display and play works fine.

I hope I was helpful.

AudioShare tells: wave, stereo, 44100 / 16, but I am not sure is that native format in audiocopy buffer or target format created by AudioShare. I dont know applications to inspect audiocopy internal data, used by developers.

I’ve fixed it, but it is strange anyway. I’ve unistalled djay from my ipad and downloaded again from appstore. Paste works fine, I’ve got waveform and bpm, it works now. I should do it before, but I was convinced, that only way to reset an app is close+restart.

I have djay since many versions, maybe updates produces merged app files in wrong way, or something was cached.

I hope the problem does not return, but i will tell you, if I will be able to reproduce it.

Did not fixed it but found a workaround.
First paste it into Djay 2 and then press record and play the pasted song. After that, the recorded session appears into the menu under the “record” button. If you load it the bmp and waveform are correctly shown.

The problem might be the name of the pasted piece, in my case always “untitled”.