Pickup mode not working Mixtour Djay 5.0.2


I find Pickup mode not working on my setup.
Scenario :
I use the filter knob for 1) filter 2) FX 1 parameter → This is stock MIDI Mapping
And whenever I touch the knob for filter after FX 1, filter goes right where the knob is, making it unusable.
Filter MIDI


I tried with the EQ knobs to map them with shift + knob for Neural effect, same problem happens.

Am I doing anything wrong? I believed this was working earlier (not sure, new user).
I tried it on both IOS and MacOS, same problem.

Running on Sonoma 14.2, Djay 5.0.2, mixtour firmware is up to date.

Thanks for your help !

Hi @Tadar,

  1. Please note that pickup mode only kicks in when moving the MIDI control beyond where it is displayed on screen.
  2. For example when changing the pitch fader after using SYNC. It does not work when the same MIDI control is mapped to multiple commands.
1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.