PIONEER DDJ WEGO2 AND Djay 2 app with IOS 8.4

I just bought a Pioneer DDJ WEGO2 and I have an iPad Air 1 running Djay 2 on IOS 8.4. The Controller is on firmware 1.03.

When I connect the iPad to the controller and bring up Djay 2 App I don’t get the Pioneer Dj logo that I am supposed to get and I can’t use the controller with the app.

I went into setting on the Djay 2 app and tried to rescan MIDI but it still doesn’t work or even acknowledges it.

How are you connecting the controller to the iPad?


We need to have a check on your controller first. Therefore, please

get the App “Midi Monitor”

connect the Pioneer DDJ Wego2

launch Midi Monitor

hit some controls on the Pioneer DDJ Wego2

In case the controller is alright, Midi Monitor should be listing new incoming Midi signals.

I know with these controllers there is a specific process to sync them. As detailed as the white cablr make sure the arrow is on the top side and you have to turn on the controller first then the ipad then turn on the app.

I’m having the same problem. I am connecting my iPad air via the supplied cable. It used to work and still works with my PC.

Thanks for your response. I’ve tried and get no response from Midi monitor. I will order a new cable and see if that helps.