Pre-cueing not working with Hercules DJControl Mix

Precueing does not work on midi hercules dj control mix. When I open the audio from the headphones in preview the audio is heard through the speakers. The configuration I have is the following:

  • Hercules dj control mix controller.
  • Split audio cable provided with the controller. Green color to the headphones and black color to the speakers.
  • USB-C to minijack cable from the smartphone to the split audio cable.
    -Smartphone Oppo find x5.
  • Paid version of Djay for Android v3.1.2

Can someone help me please?

Thanks in advance. All the best


It works flawlessly with the iPad. Do you have Split Cue enabled for the headphones in the settings?

Yes. All the set Up in the djay app is ok. Maybe, it could be a problem from audio Split cable provided by Hércules (Green and black colours)? I’ve just ordered a traktor audio Split to verify It. When i turn on the music and sound Up headphones volumen control the music goes also to the speakers.

I’ve the same problem in Android and iOS…

Hey @Zorrobueno - Sorry to hear you’ve been experiencing this issue with the Split-Cue! The Traktor cable in my experience has been very reliable.

Please let us know if you have any updates when it arrives! Looking forward to hearing back. Feel free tor reach out if you have any other questions in the meantime.

Is the hercules controller bluetooth or does the Oppo find x5 have a headphone jack?

I have the same problem. When I connect my reloop beatpad, precue and master play through the master output on the controller.

Unfortunately when the controller is connected, i cannot re-route the audio anywhere else i.e. to a usb c hub adapter via headphone jack. It’s as if the controller overrides everything else and won’t allow changes to be made.

I’m having this same issue. Does the splitter that comes with the device not work for pre-cuing?

If the audio is routed through the controller, you can split the RCA outputs instead i.e right RCA (red) master, left RCA (white) headphones.

I have the same issue on iphone and ios with the latest update. Did not have this in the past…

1 Like

Are any mods or support members reading these threads?

Hi @RazlDazlRalph, please provide specific details about your setup not just “iPad” or “Latest Version”. This helps all of our community moderators to provide the most effective support to users with the utmost efficiency. Thanks!

Device Model (ex. 2020 iPad Air 4th Gen):
Version of operating system (ex. iOS 17.3.1):
Version of djay (ex. 5.1.3):
Hardware/controllers used (ex. Reloop Ready):

Please also describe your issue in as much detail as possible.
What has changed between when it was working and stopped working? This will help us troubleshoot your specific issue.


Sure thing

Device Model (ex. 2020 iPad Air 4th Gen): Iphone 11
Version of operating system (ex. iOS 17.3.1): iOS 17.4.1
Version of djay (ex. 5.1.3): 5.1.7
Hardware/controllers used (ex. Reloop Ready): Hercules DJControl Mix

In the past I could connect a speaker via bluetooth as master out in the app and my headphones via a jack for precueing, alllowing me to really properly mix. Now I can’t get any sounds via the wired connection. Precueing also happens via the main speaker/main output. Even split output with both speakers and headphones connected via wire only sends music to the speakers channel.
Am I doing something horribly wrong, has this changed over time? I’ve tried a number of setups but no success so far.

Thanks for the info @RazlDazlRalph. This topic was initially focused around Android, but I’ve adjusted it to include iOS.

  1. Please share a screenshot of your djay Settings>Audio Devices page.
  2. Also share a screenshot of your djay Settings>MIDI Devices page.
  3. When you say your “headphones are connected via a jack”, are you using a genuine Apple USB-C to Headphone adapter?
  4. How are you powering the Hercules controller?

I read through the Hercules DJControl Mix User Manual. Please review the following setup procedure from the manual (

  1. Connect the speakers/headphones DJ splitter cable to the headphones output on your smartphone or tablet.
  2. In djay, tap the Dashboard button, then tap Settings to access the app’s settings.
  3. Enable Split output – Enable split output for precueing with audio adapter.
  4. Connect your headphones to the green output on the speakers/headphones DJ splitter cable, and
    your speakers to the black output.
  5. When you want to monitor a track, simply push the Monitoring button corresponding to the track that
    you want to monitor.

Thanks, I have the manual and tried those steps. I will share some pics of my setup and the screenshots you requested shortly

Hi, I just ran a few more tests and got it working again in line with the instructions from the manual. I think I must have been switching audio devices too much and the software got confused. THAT SAID, what would be a real blessing for the Control Mix would be if Algoriddim allowed the master to be played over bluetooth, while still allowing wired pre-cueing on headphones.(for the sake of portability and using it with a variety of speakers, not all of them have aux ports)

Thanks for the follow up. Glad you got it sorted out. That has been suggested before, but unfortunately, that functionality is currently locked down by iOS.

Oh dear, I hope they do unlock that option one day.

1 Like