Pre-Queing doesn't work with my "Hercules DJControl MP3 LE".


I recently bought a second hand “Hercules DJControl MP3 LE” USB/MIDI-Controller.
I’m using it on my laptop that’s running on Windows 10 Home (x64).
The controller is directly conected to my laptop trough USB.
I’ve got a “Focusrite Scarlett Solo” as audio-interface, my headphones are connected to it and my “Hercules DJ Monitors 32” as wel to function as speakers.

I’m currently trying to get it to work with DJay Pro (Demo). The software recognizes my controller and all of the mapping should be automatically in order.
When I press buttons on my controller it reacts with the software, exept the button with the headphones symbol on, if I should press that button in, it should only let me hear the music trough my headphones and not trough my speakers as well right?
Also as soon I hit that button both the decks headphone monitors stay activated and can’t turn them off anymore.
It’s always playing trough my speakers and my headphones at the same time, so I can’t pre-que songs trough my headphones. After trying for a while it seems like the software is stopping to work and the other buttons don’t work anymore as well.
Sometimes the software just shuts down as well.

Im really keen on using DJay Pro, I know I can only use it for 15 minutes in the demo version, but I’m not going to buy it if I can’t get it to work :confused:

(On the image it’s nr. 20 for headphone monotoring.)


Thank you for your post.

Could you please check if your setup is working if you select the Hercules DJControl as master output and your Laptops Headphone Jack as Pre Cueing channel?

Thank you in advance.

I have been trying to use djay pro for windows for some time now and it eventually work on windows 10 using unmarked Mixtrack pro then platinum however so many glitches and faults occurred that I eventually bought a MacBook Pro and now works fine no glitches no problems works like a dream so I suggest if you want to stick to windows use another software if you wanna use algorithm go iOS or OS10 or later NOT windows

Hii, thankyou for your reaction!

At the tab “Configure audio device” I can select;
Main Output, Device -> Focusrite USB (Focusrite USB Audio)
This are my speakers connected to the audio interface then.
The only other option is “Speakers (Realtek High Definition Audio)”

Pre-Cueing, Device -> Speakers (Realtek High Definition Audio)
That are my headphones connected to the laptop.
The ony other option at the Pre-Cueing section is “Splitter Output” or “None”

With this setup I still hear the same music trough speakers and headphones at the same time.