Prevent automix to reload deck?

Hi,

I’m not a DJ, I just like automixing and I use it with Tidal in HiFi mode, so loading tracks take a while. Unfortunately, I often have to update the end point, because it’s wrong. For this I have to disable automixing temporary to not trigger the transition when updating the end point. When I re-enable automix, it will reload the upcoming track, though.

I do shuffle my Tidal playlists and I wish to continue to do so. But reloading the other deck is very bad, because it will throw away the old track that I downloaded in HD. If I do this often (and I need to) I generate so much more traffic, which I would like to avoid.

Is there a way to enable automix without reloading the upcoming deck?

Hi @Automixer, Thanks for your question and sorry for the delayed response. I’ll be happy to help you out with Automix. It sounds like it may be just a matter of changing the settings to be able to use Automix as you’ve described. But to be sure, it would really help to understand how you’re currently using Automix in more detail and to see what your current settings are.

Could you please share the following:

  1. Which djay version are you using?
  2. What mode are you using Automix in (e.g., Automix, Classic, 2-Deck, etc.)?
  3. Please send a screenshot of your current Automix settings (in djay’s Preferences).
  4. If possible, sharing a video of exactly the steps you take up to the point where Automix reloads the upcoming track would be really useful to understand your workflow.

Thanks in advance for the additional information.

Hi Emily,

thanks for the reply. Let me first answer your questions:

  1. Latest (3.1.3)
  2. Automix mode
  3. Screenshot of my settings:
    Screen Shot 2021-06-10 at 16.30.34
  1. Attaching a GIF animation illustrating the issue:

The track on the right at the beginning of the animation is in fact load from automix, yet it will be swapped with another one when I disable and enable automix, which is annoying and bandwidth waste when you listen to HiFi music over Tidal.

I have to disable automix to adjust the end point of the current track to not trigger automix, but then I have to re-enable it. I also want to keep the settings as they are, because I want them to be like this, i.e. enable shuffle.

If I load a track via automix before, it should not reload a new track when I disable and enable automix, again. I haven’t touched the deck, but it will load a new track. This is not very nice when you are on a data plan while listening on Tidal.

I would think otherwise if your app would cache Tidal music.

Thanks for the additional information, and thanks also for sending the animation over. That’s very helpful to see what you’re experiencing. I’ve just tried to reproduce the issue on our devices here using the exact same settings and steps that you’ve described, but wasn’t able to do so. The upcoming track (on the right of the screen) stays the same when I select “Stop Automix” and then “Start Automix”.

I’ve passed the information you’ve shared on to our development team for further investigation to determine what might be happening here. I’ll keep you updated as soon as I hear back from them. Thanks in advance for your patience.

Hi @Automixer,

As we haven’t been able to reproduce the issue here, I have noticed in the screenshots you’ve sent that you have a setting in your Automix Preferences menu that shouldn’t be there. Specifically, the Automix List “Shuffle” setting shown below:

settings automix mac

It would be interesting to see if this is somehow contributing to the Automix behavior you’ve described. First, could you please either update your djay Pro AI software in the Mac App Store (if an update option is available to you), or reinstall the software, and let me know if that option still shows up for you in the Automix Preferences menu?

Could you also let me know if, after either updating or reinstalling the software, you encounter the same Automix issue? Or does this solve the issue?

Thanks in advance for your help troubleshooting.