Pro 2 Library Search not functioning

Just downloaded djay pro 2 and it won’t search my external hard drive. I type in an artist and it will pull up 2 tracks when I know I have dozens by them. Or it will say No results. I open djay pro (not 2) and the search works amazing. Is there something I need to do with pro 2 to get it to search properly?

1 Like

Had the same problem… Found a workaround! 

drag and drop the parent folder into the djay library and use the search there  (vs finder integration)

Your Library on Djay (the crate icon on top, that is) will include any song that you’ve added to a playlist… the search and filtering will also work. 

For me, at first it seemed like nothing was happening, and then an “importing items” browser came up. Overall It took about 10ish min to import 7k songs. 

You’ll have to manually add new downloads of course.

I am curious whether having a larger djay library will slow down the program at all, but i hope not! Tried a few searches before posting and it was working quite well.

Hi there,

thank you for your post.

Can you send us a screenshot of the two search results via

Thank you in advance.

Hi JR Burrows,

I want to apologise for the belated response.

Can you send us a screenshot of the folder overview in your finder in which you are searching for the same two keywords:

“mich jack”
“michael jackson”

Thank you in advance.

Hi there,

also it would be interesting if you purchased djay Pro 2 out of the App Store or via our website.

Thank you in advance, we will do our best in order to help you as fast as possible.

Lukas E.

Hi there,

I am sorry. Please stay with your version, this information is only helpful for us. Where did you sent us the screenshots, did you do so via mail?

Just sent the reply:


Here are 2 screen shots of me searching for Michael Jackson (to which I own every song). I just wanted to show that I did a partial title search and then I completely spelled it out. If I type “beat it” it shows as No Results found

Still no answer?

I guess I wasted my money. No response isn’t good business. I mean 8 days. 8 damn days

Hello, I complied over 10 days ago. Could I please have some sort of reply?!

Look… here’s the deal. I’ve been responding via email to no answer. If I delete my download, which came from the App store, and re-download from your website - Will that fix the issue? Also, will I have to pay double? This is very frustrating. I connect my harddrive, I even re-index it, added the folder to your software… and it isn’t searching anything. I’ve sent you screen shots. I just want a solution

Are you using a Mac or PC

I’m having the same problem. Not very happy. Not only is the search not working, there’s no option for me to recurse the root folder and show all songs from every sub folder in the list like what iTunes does. I have to go into every sub folder to view it’s contents, and on top of that, the search is barley functional.