Problem with djay pro on android

Hi guys, I purchased the pro version of djay through google play store and for some reason it has reverted back to the free version and I am now seeing the “buy now” message when I open the app and use the samples. The message also pops up when I try to split the audio which then stops this function from working.

I have tried clearing app data and cache and I have also uninstalled the app several times but everytime I reinstall it I only have the free version.

I am using the google account that I purchased the app on, before anyone asks and this is the same on both my phone and tablet.

Has anyone else experienced this problem and if so, how did you resolve it?

Hi @Wardy1, thanks for your message. Are you part of our public beta on Google Play? If so this was a known issue with one of our recent beta releases, which has subsequently been resolved.

Please download the latest djay update in the Google Play app and let us know if you have any further issues. Thanks!

I have uninstalled and reinstalled the app many many times. I was in the beta program but I left that and downloaded the normal version of the app but still had all the same issues. I have also rejoined the beta program and downloaded the app again. Unfortunately i always get the “buy now” message come up and various key features are locked. I also contacted Algoriddim via email some time ago but haven’t had a response.

Sorry to hear re-downloading didn’t resolve the issue for you before. Please note that the issue was resolved in the latest update, which was only released yesterday.

If you download the app again and the issue persists, can you please let us know the version number shown at the bottom of the djay settings panel so we can further investigate this issue.

I have tried everyday. I uninstalled it and reinstalled it both today and yesterday but the app is still locked and displaying the “buy now” message.

The version number is 3.0.16

Thanks. Could you please try joining the beta once more in the Google Play app, to see if the latest beta build from yesterday resolves this for you?

I have done that already. I left the beta program, downloaded the app, uninstalled it and then I joined the beta program and installed the app. I’ve been doing this everday since the issue first appeared.

Thanks for the screenshots. If you’re in the beta program, the app version number should be 3.1. Is that not the case?

I am getting the feeling that Google Play might have gotten confused about your account for some reason… :thinking:

As you can see from the screenshots, I am in the beta program but there hasn’t been an update. I have uninstalled and reinstalled the app multiple times today and the version is always 3.0.16. If I go to google play now, there is only options to uninstall or open the app. There is no update option.

Is there a way to force the update?

Well, after spending most of my day messing about with djay on my phone, I decided to see if I could get the app updated on my tablet. The update was available on there so I updated the app to 3.1.

Unfortunately this version has some new problems of its own. When I go to load a track, my devices music library is not available anymore.

I then downgraded back to 3.0.16 and my music library is available once again but the app is locked to the free version.

It might be worth noting that on version 3.0.16, the app actually asks for permission to access my devices storage but unfortunately this doesn’t happen on version 3.1.

So in conclusion, I either use the app without headphones/pre-cue or I have the ability to use the pro features but without my music library.

@Anders are you still there? I’m having a lot of difficulty getting this working how it should. I have spent way too much time messing around with this to still be in the same position I was several weeks ago.

At this moment in time, it seems the modded version of the app that I found after a few google searches is the only option that I have.

Thank you for the further feedback. We’ll look into the issue you reported about the music library not being accessible in the beta. As for the purchase issue in the 3.0.16 version I believe this is unfortunately a side effect from switching between the beta and non-beta versions triggering this issue in Google Play. We will check if this can be worked around for future updates.

I didn’t keep switching from beta to public versions of the app!! :rofl: why on earth would I do that for no reason? I only switched to non beta after the issue was already present and after I had tried everything else.

Previously the app was working fine and I didn’t change anything. I launched the app one day and the “buy now” message was displayed on start up. I hadn’t changed any settings at this point and the problem just appeared one day. This was nothing to do with me.

Presumably the app updated itself and there was a bug with the new update. Obviously I contacted Algoriddim support via email but didn’t recieve a response so I was then left with no choice but to try and work it out for myself.

Firstly, I forced closed the app and reopened it again which didn’t fix the problem. I then cleared the apps cache and reopened it again. I then cleared the apps data (losing all my settings and reverting back to default). This also didn’t fix the problem. I then uninstalled the app and reinstalled it, this did not fix the issue, I then left the beta programme, unistalled the app and reinstalled it. This did not fix the issue. I have since then tried uninstalling and reinstalling both versions of the app, public and beta, every day which also didn’t fix the problem.

It was only after the 3.1 beta version became available yesterday that I regained the pro features but the update still seems a little bit glitchy as on first time launch, the upsell page still appears but then isnt present with subsequent launches. If i clear app data, which i have done several times, it flashes up again.

Unfortunately there is a new problem where permission to access device storage is never asked for so the app never tries to access the music stored on my device. When I click on “music” the library is empty. I noticed there is also another category in that list “djay music” which does open but doesn’t contain any of my songs.

I have gone into my device settings, app settings, permission settings and tried to enable the storage permission manually but it is not listed so I am not able to get this working so basically I am stuck without a my music library.

I am in a worse situation now with 3.1 than I was with 3.0.16 because even though I had an issue with 3.0.16, I had actually found a workaround to get everything working.

Reverted back to 3.0.16 (non-beta). Music library has returned but lost pro features once again. Installed the modded app from apkmody and everything is working as it should be.

The main reason I joined the beta programme was because I thought that the midi controller audio routing issue would get resolved at some point but the problem has existed for years now and after reading the threads on here, have lost all hope of that ever getting fixed.

Best option for me is to turn off automatic updates and stick with the modded 3.0.16 version.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.