Problem with the Master out Hercules Rmx2

Hi there everyone, it’s the first time i post here,sorry if my English is a bit bad…
I djay with ipad 6 generation latest update.Latest version of djay AI as well…
I have just purchased a Hercules rmx2 that is supposed to work natively with djay AI…
My surprise is that every thing seems to work quite well apart from the master vol out.(cue headphones work)
The knob on the controller when moved, moves the master in the app but no sound comes out.
The configuration of the channels are correct and se sound setting restriction is deactivated.
I’ve tried downloading the app Djuced(That suks😖)and works perfectly! Master vol,cue vol, buttons…
So i know what it is not problem of the controller…
If anyone know’s about what is going on I’ll really appreciate some info.
Thanks guys :raised_hands::pray:

Hi @Alex_Lovell, welcome to the community.

  1. First, please confirm that you are using a Genuine Apple Lightning to USB 3 Camera Adapter to connect your iPad to the RMX2. There are known issues with 3rd party adapters (Lightning to USB 3 Camera Adapter - Apple)
  2. Make sure the Apple Adapter is also connected to your original iPad charger and cable and that your iPad is charging.
  3. Please provide a screen shot of your djay Settings>Audio Device Setup.
  4. How are you connecting your RMX2 to your audio system (XLR cables or RCA cables)?
  5. According to the RMX2 manual, the main volume knob on the controller only works for the XLR outputs.
  6. So, if your speakers only support RCA inputs, you will need to use XLR to RCA cables.


Thanks for the answer! My cam adapter is original, cable and charger as well.My settings are the same…
I have a Hercules starlight and have no issues…
Yes i Connect via rca to sound system.The thing is that the master knob works in the app,it moves it but no sound comes out.
If i use Dejuced whith the same configuration (rca conectors) sound comes out fine…
Saying that,if i run other apps like geoshred master vol works as well.
I will try what you say and get some XLR to RCA…but it’s suspicious that it works fine with Dejuced.Thanks a lot!!:pray::pray::pray:
(An other question is shouldn’t it work manually directly on the ipad?)(the master)

You’re welcome @Alex_Lovell. I’m pretty sure the issue is with the audio outputs on the RMX2.

  1. You could try changing the Main Output to a different channel.
  2. You could also check the drop down menu for the Booth output and making changes there.
  3. However, if the RMX2 behaves like outlined in the user manual and you are connected to the Booth output, the volume control on the RMX2 will not adjust the output volume on the Booth output. I don’t have access to an RMX2 myself so I cannot confirm how this works 100%.

Thanks a lot!! I will try all this things…
Tomorrow I’ll be recieving the xlr cables.
I’ll post again as soon as I get it working :sweat_smile::pray::pray::raised_hands::raised_hands:

Great! I hope that helps. Please report back here.

1 Like

hi there, I’ve received the xlr cables.No differents,still no sound comes out of the master. i did what you said,and fiddled whith the channels and nothing!!:confounded:
If I select the option of ipad speaker it works fine…the master knob increases and decreases volume.

I’ve tried with djuced,and the same, no trouble at all.With rca or with xlr cables

Hi @Alex_Lovell, sorry that didn’t work. I’m not sure what else to suggest here as all of your settings look correct. Have you tried contacting Hercules support?

1 Like

Thank you, I’m going to get rid of the Hercules and get a vestax…
I don’t like the modern controlers…all plastic.
Thanks for the help anyway.

You’re welcome @Alex_Lovell

Hello,back. I’ve given my rmx2 a last chance and tried it today with an other sound system(much powerful)…
And the master works!!! But at very,vey low volume… I’ve investigated a bit and found another person with the same issue.
As said before,i think is an issue with Djay pro not the controller…as it works perfectly with other softwares.
(I’ve contacted Hercules,but still waiting for a answer)

My problem is exactly what :grimacing:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.