Problems with Mixon 8

Hi djay community, i use the Mixon 8 with latest firmware and update of djay, but i met a lot of problems with commands:
Numbers between […] are numbers controls buttons of the instructions manual.

On Deck 1 : SHIFT[48] + FX 2 Arm[30] → This command assign FX on Harmonic for Deck 1 and 3, but we want it just for the Deck 1 not for the Deck 3.

For all Deck : SHIFT[48] + TAP[34] → Doesn’t toggle between “Neural Mix mode” and “FX mode”.

Deck 2 and 4 : Button “vinyl mode” isn’t light when we do SHIFT[48] + Slip[36].

Deck 2 and 4 : Button “reverse” isn’t light when we do SHIFT[48] + Time[37].


I’ve got a lot of shutdown with my iphone, the controller deconnect at anyone time… i’ve already used djay on my iphone during 5 months with DDJ-FLX6 and i’ve never encountered this before… i’m in a reflexion to resell my mixon 8 seriously :cold_face:

@Clem_Coss I haven’t had any shut down or disconnect issues with the Mixon 8.

  1. What iPhone and iOS version are you using?
  2. What Mixon firmware version?
  3. What djay version?
  4. How exactly are you connecting the iPhone to the Mixon 8? Ex. Apple camera connection kit with USB-A to B cable to USB-A on the Mixon
  5. Are you doing anything in particular when the disconnects happen? Ex. Running 4 decks, using Neural Mix or streaming songs from Tidal.
  6. Are you using the default/built-in MIDI mapping or a custom one?

The more information you can provide the easier it will be to troubleshoot your issue.


Okay, thank you for your feedback !

During my different test i’ve encontered 10 shutdowns aproximativly for a week now.
I use iphone 8 with ios16.5 version, the last firmware version 4936, the last djay update 4.1.9., my connection is a cable lightning to usb-c, i tested my mapping and the defaut mapping.
(I know that my iphone is too old because sometimes djay app can take some time (~1s) to charge when i want use stems😅)

So i can make my opinion, the shutdown happen in 5-10 minutes generaly (not always) after i started to mix, without particular when it happen (with 2 decks, with 4 decks, with and without stems activaded)
When i restart the controller after a shutdown, generaly the controller don’t shutdown another time… but when it happen it’s so sad :cold_face:

@Clem_Coss my gut feeling is that it’s an issue with your older iPhone.

  1. Have you tried a different USB cable?
  2. Do you have another iOS device you can try? Maybe a friends iPad or something.
  3. Are you using music stored on your phone or streaming services?
  4. How much free space do you have on your phone? Try deleting some stuff if your storage is low.
  5. Make sure all other apps are closed when using djay and turn Bluetooth off. Wifi too if you’re not using streaming music.
  6. If none of this works, I’d recommend backing up your phone, doing a factory reset then a full recovery.

Hey @Clem_Coss - Welcome to the Community! Thanks for your first post.

It looks like @Slak_Jaw is on the right track regarding troubleshooting steps for you.

We look forward to hearing back from you and hope the questions and suggestions provided so far will help identify the source of the issue.

Please let us know if you have any questions. We look forward to hearing back from you. Have a great day! :slight_smile:

1 Like

Yes i hope that it’s my phone who can’t make the power for my using :pray:
I think it’s very random :sweat_smile:
Thank you @Slak_Jaw, and i keep the mixon 8 for the moment :face_exhaling:


@Clem_Coss you’re welcome. I hope that helps.


Hi Alyx, the mixon 8 is a very interesting controller to combine fx and stems, but I have a suggestion to make it more powerful!
Make the fx units able to activate each fx for each deck (like the software) because in the current case, for example: when I have pre-activated the first fx in deck 1, the first fx in deck 3 is also pre-activated (also for the second and third fx for the left decks and it’s the same for the right decks)
I can’t choose which fx is pre-activated or not in each deck…

I think the best solution is to have a mapping with something like: Fx Unit 1 modifies the effects of decks 1 and 3 according to Deck select [49] on the left side (also for decks 2 and 4 on the right side).
But we don’t have a button mapping for “deck 1 or 3 selected” and “deck 2 or 4 selected”.
Tell me if we able to have this mapping in current conditions ?
If not, I’ll take my sadness in patient. :fire:

Hey @Clem_Coss - Thanks for getting back!

I’ve reached out to our dev team, and it seems that we worked with Reloop on the mapping for this controller, and the current behavior is expected.

That being said, we see where you’re coming from! I’ve notified the team internally. We’ll keep it in mind and let you know if there is any change.

I hope this helps. Feel free to reach out here in the Community if you have any further questions or suggestions, and have a great day!

1 Like

Thank you for your answer !

I’ve another problem for about 3 or 4 days, sometimes the left jog doesn’t detect my hand when i want to scratch or move backward in the track… I’m going to return the mixon 8 to the store because as there are a lot of problems now with this controller…
It’s a cold shower seriously :cold_face:

1 Like

@Clem_Coss you might want to try reinstalling the latest Mixon 8 firmware before you give up completely and return it.

1 Like

Ok but how you do that :sweat_smile:

You can find the latest firmware near the bottom of this page. Follow the instructions carefully to ensure it’s installed correctly.

Video tutorial for firmware installation:

Sorry i understand the firmware before the latest :sweat_smile:

Hi, I had the same issue on the right jog wheel and called in for assistance yesterday (12-11-23). I was advised to update the firmware. First I checked my current version and it was the same as the latest version. I still went ahead to re-update and my jog wheel responsiveness is back.
I think the update has fixed the problem.
Let me test it more and come back if anything

1 Like

I had a similar issue where I had to reinstall the firmware a second time before it worked properly.

That’s very strange… :thinking:


Thank you Kindly
I did exactly that yesterday and it’s working now. Scaryyy !!!
Thank you so much

Dj OneKlick

@Djoneklick you’re welcome. Glad that worked.