Quantize of Hot cues not working well.

Hi all. I am a longtime user of serato and denon prime standalone units And their quantiise when I’m jumping around hot cues is perfect. For some reason in DJay pro ai This is not the case. The only way to have things perfectly in time is to hit the performance pad a little early. Does anyone else have this issue? Is there a way to fix it it? I want to add that this is a dealbreaker for me. I was going to change my software, but if this doesn’t work, I can’t.


Hi @Nubium,

  1. I recall a small adjustment when I switched from Traktor to djay Pro years ago.

  2. I recommend you play around with the Quantize and Sync settings to see if you can find something closer to the “feel” you’re used to.

1 Like

I have already played around with those. But I’ll have another go as I said in Serrato, and on my Denon prime Hardware this works perfectly. It’s such a shame because I’m loving everything else about it. I’ll test it on my phone and I’m getting a new iPad soon so maybe it will be more powerful than my 2018 Mac

I have iPhone and pretty new iPad and I don’t have this issue. I came from Denon also and Traktor and I just can’t go back. Hopefully it will work out for you.

Thank you for your reply. I’ll do some more testing.

Which iPhone do you have? I have the 12 pro.

15 pro max. The 12 will run neural at 100% though as well

Can you do me a favor and test the quantize hot cues on your phone and purposely press the hot cue a little late? In Serrato, the track will keep playing exactly in time and even if I press the button late it stays in time. Maybe it’s just the behavior of this app because if I press the button early, it’s always in time.

Yes of course. I’ll test tomorrow. Just watching a programme with my wife. Better not dash off now or I’ll be in the dog house😂

Understood. Have a good night. Thanks for your help.


  1. I’m pretty sure if you press the hot cue late, djay will quantize/sync this to the next beat or fraction of a beat depending on your quantize setting. That’s what my testing indicates at least.
  2. It does not quantize to the closest beat, in your case the previous beat, but instead to the next closest.
  3. Like I said above, I believe I noticed this when I first transitioned from Traktor, but I quickly got used to the different way djay behaves so I don’t notice anymore.

Thanks for your feedback. Much appreciated. It’s such a shame. It doesn’t behave the same at other software. It does make sense for quantities to do that, but not musically because I need the bars to stay In time, not becoming a 5/4 bar

You’re welcome.

  1. Is the main issue that your workflow requires your hot cue press timing to always be a bit late or is it a muscle memory thing and something that you’ll adjust to?
  2. Does it help to keep your phrases in line if you change the Quantize from 1 to 4 or if you change the Beat Sync Interval in the Settings>General>SYNC MODE from 1 Beat to 4 Beats?

I guess quantize for me. The whole idea is that if you’re a bit late or a bit early, it will keep you in time that’s what other DJ software apps do. I’m not trying to do it on purpose. It just happens.

1 Like

Understood. I’ll discuss this further with the engineering team to see what they think and if this can be adjusted.

What would you say would be the best quantize setting?
Also does it make a difference if Quantize is on or off?
I mean if I have Quantze turned off, does it matter what beat setting it’s set at?



If quantize is turned off, none of the different quantity settings will make any difference. When you’re using hot queues, do you only ever jump to the start of a bar? If so, then you’re fine using four beat settings. Does that make sense? However, my reason for starting this topic in my issue is that quantize in this app is far less superior than every other app that I’ve used.

I do know what you mean. Traktor also has ‘snap’ which means if you are slightly off it will snap to the beat. Very useful.

1 Like

Exactly. In my mind this is what quantise should do.

it might be my imagination but even if Quantize is turned off, if I have it set at 1/16, I feel it acts like it’s switched on…
I generally set it at 4