Rane one control knob issue v4.03

This has been mentioned in another post, but worthy of its own bug report.

The master volume knob and EQ knob for deck A are not working correctly since the 4.03 update. Turning either of the dials through a full rotation intermittently sets the level to max or off.

1 Like

I have noticed this as well, even if auto gain is on or off,

1 Like

Have you experienced the flashing cue buttons as well?

Have you experienced the flashing cue buttons as well?

I don’t think I have, I notice that between songs it often sets all the performance pad title buttons to blue though?

@Timothy_Refile @maurizio_T

Are you guys also experiencing loops constantly defaulting to 16 beats? This used to always stay to what I had on the last loop setting - so I typically use 8 beat loops, now I’m having to change it from 16 to 8 every time.

I haven’t tried that yet but I will try it on my backup ipad of which has the latest update and get back to you…

1 Like

Yes that is what I am referring to, whenever I press the track select button to select another track, the performance/cue pads momentary blink default light blue…

Hopefully with the next update they don’t forget about using the glitch when using the search function and having the searched track try and load to the track already playing which came from update 4.0.1

New update out, anyone tried it yet?

@Anders @Emily

Here is a video demonstrating the issue, I’m slightly turning the dial (mapped to neutral mix instrumentals volume) and you can see both on the wave form and the neural mix interface how it’s jumping about. Obviously it’s cutting the audio too.

https://youtube.com/shorts/bni-42ePsug?feature=share

This is the same issue with the master volume, but I’m not going to demonstrate that, I don’t want to blow my speakers.

Thanks for the video @Private_Repress. It looks like you might be using a custom MIDI mapping – does the same also happen for the EQs when using the built-in MIDI mapping? And can you also reproduce it without any track playing or being loaded?

We haven’t been able to reproduce this issue so far. To determine whether this is caused by the software or the controller sending intermittent MIDI messages, could I ask you to please download the MIDI Wrench app, connect the Rane One to your iOS device, and turn one of the EQ knobs? In the right-hand panel labelled “Incoming MIDI Events” you should be seeing MIDI messages coming in while you turn the knob. The number at the end of each line labelled “value” should usually be consecutive numbers going from 0 (full left position) to 127 (full right), unless you turn the knob very quickly, in which case some in-between values might be missing.

Please check if the values are actually consecutive, or whether the controller might be sending other values or messages in between. Thanks for your help!

3 Likes