Rane One - not being recognised by default

Hi guys,

It’s not a major issue, but more of an annoyance. Each time I open up djay on the iPad Air 2020 I have to manually search for MIDI devices to recognise that the Rane One is connected.

This never used to happen, it would have previously just establish the connection automatically and load my custom midi mapping profile.

Any thoughts?

Djay version 3.8.2
iPad iOS version: 15.1

Hey @Private_Repress,

Thanks for pointing this out to us. We completely understand that you’d be annoyed by this.

Do you by any chance remember when this used to work? Has it been this way for you since version 3.8.2 (released October 25th)?

I’ve reported this to our developers and we’ll keep you posted with any information.

Thanks again for helping us improve djay.

Cheers, G

1 Like

This has happened to me before but it’s rare…It does happen though if I let the iPad go into sleep mode with the Rane One on…

Make sure “usb accessories” is turned on in “Face ID & passcode”.
The iPad will power down the usb after an hour of the screen locking and this can be a cause for having to wake it up again.
It’s there as a security measure to stop someone plugging in a usb device when locked and having access to your data, but it doesn’t help dj’s that setup early, lock the screen/iPad and come back later, unlock an expect the controller to work right away :wink:

Let’s hope that the issue and you haven’t found another problem that needs a new solution.


Great Tip, I’ll try that and see if it makes a difference…

1 Like

This sounds logical, and I assume the functionality was added along with iOS 15.1

I’ve just changed the setting to see if it makes a difference.

Thanks mate :+1:t2:

Thanks @Guillermo, the suggestion that @SteNight had seems to have solved the matter.

Thanks again @SteNight

Hi there.

Function was added back in ios12 but it seems to cause problems for various people in iOS 14.
I first noticed it when I was using Automix with the screen locked but still using the controller to move to the next track or change volume etc. Sometimes the controller wouldn’t respond but the music kept playing. That’s when I discovered the USB restricted mode was turned on.

Not saying that this is your issue, which could turn out to be another Raine only problem, but I prefer having it turned off.
There are talks online about apple removing the 1 hour grace period which would mean the controller would stop working as soon as the screen locks :flushed:.


I think I spoke too soon, just tried again and had to rescan :man_facepalming:t2:

@Guillermo please keep it open with the developers.

It seems to be since I moved to the latest version of djay, or iOS 15.