Rane Twelve Mk2 and Rane One - Cue Points are slipping out of positions.

@Guillermo also are you able to confirm exactly what has been tweaked for the rane one? I can see that the performance pads now also have the double feature set, ie pressing hot cue once enables the pads to jump to a cue point, pressing hot cue again alows to jump to a cue point with an immediate loop etc. Would be great to know what else has been changed?

OMG! This new 3.7.8 update made the accuracy of the Cues much better. I got carried away in training. Once again I leave my sincere thanks for the attention given and to the entire team. :pray:

1 Like

Hello folks. I’m new here and only recently jumped on. But I have the same problem as you describe here in this thread, that I have an enormous cue drift when scratching and beat juggling.

The cue always drifts counterclockwise and i’ve tried almost everything. Spacer ring under the plate removed. Other slipmats. High- and low torque. USB directly in the hub of the mixer, as well as with a powered USB hub, or directly to the laptop.

Besides, the fans of my computer always go very high. Accordingly, the temperature of my CPU is always quite high (over 100 degrees Celsius.)

After a longer time of playing, then mostly nothing works anymore. djay Pro no longer responds to my Twelves. The waveform only jumps forward and backward briefly when the plates start and stop.

My System: MacBook Pro (Retina, 13-inch, Early 2015) 3.1GHz Intel Core i7, 16GB 1867MHz DDR3, Intel Iris Graphics 6100 1536MB

macOS Mojave 10.14.6

djay Pro AI 4.0.2

My setup: Reloop Elite with Firmware V1.06, 2 x Rane Twelve MKII connected via the USB hub of my Reloop Elite

Can anybody help?