Same track on deck 1 and 2, sync 'overkill'.

Good day!

If you load the same track on both deck 1 and 2, with the goal to mix independently, this works fine if sync mode is off. But after switching on sync (bpm and beats, maintain on song load on) the tracks get synced on the exact same beat nr, i.e. the track in second started deck jumps forward to the exact beat nr. of the track that was already running in the other deck. I would expect the second track to sync to the nearest beat, just as if a different track was loaded. Bug?

Thanks and kind regards, Bart.

DJay 4.1.9
MacOS 13.4.1 (c)

1 Like

This isn’t a bug. This is the way djay currently handles Instant Doubles. This feature is useful, but I think a setting should be added to enable/disable it.


Yes, in that case a setting would be useful.
Although this use of the sync principle seems less useful to me because it produces awful audio because it is not phase synced.

This is definitely a bug… Syncing is not the same as instant double… @Brainbox did well explaining the bug… Its supposed to sync to the nearest beat not clone… It might seem normal to other djs… but if you doing complex skills with multiple tracks in one song… Its definitely a bug… For instance… I have one track with an acapella and a beat …merged into one… When i mix them… I want the acapella to sync to the beat not to clone… Instead the app will clone when i press sync… dealing with hiphop and dancehall i have as many as 8 tracks in one song… I decide which beat goes when… And since i want everything to be smooth… I use sync to pull this trick… But when it clones instead of syncing… Oooh its becomes a desaster…:grinning::grinning::grinning: … So this is a bug because all other software dont behave like this… When i say all i mean virtual dj… Serato… Recordbox… Not that i dont know how to do it manually but sync just gives me comfort…:stuck_out_tongue_winking_eye:

1 Like

I hear you and I absolutely understand why you want the option to turn the current, and unusual implementation, off. Really sync should behave the same no matter what track is playing and Instant Double should be handled separately and not automatically like this. Until this is changed, the work around is to turn sync off and manually aligning the beats of your choice. I realize this gets more complex with 4 decks and other things going on, but it’s not technically that difficult to master.

1 Like

Hmmm, interesting, instant doubles, learned something new.

>> edit: removed bad joke …

I also found this, it seems you already have a choice to have the second loaded track to be instant double or not. If you load the second from the queue, i.e. the same ‘instance’ from the queue that was loaded first, it is treated as instant double. But, if you load the second track from the playlist, but still the same track, it is not treated as instant double, and you can be creative with it. If you put two instances in the queue of the same track and load these, it is still treated as instant double. I wonder if this is intended that way, looks a bit shaky to me, but at least in this version there is a workaround.

1 Like

I also found this.

A switch on/off would be
a) clear for new users (“is it a bug?”)
b) set creative energy free

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.