Sampler is not Velocity sensitive?

I have assigned a note to the sampler as target.
When I play a key it is always playing at the same level!

Really? That must be a bug!
Velocity sensitivity is there since the 80ties, guys!
It´s only a number you have to multiply with the sampler volume!
I am not asking for proper filtering and smoothing the attack at soft velocities - even that would be not hard to code! I have done this - took me 30 minutes for my audio engine 20 years ago.

Velocity sampling works fine on my DDJ-SX2.

It’s built into the Pads and has been coded to function exactly as expected.

Maybe they’ve not coded it for your controller.

If you update the thread with the hardware you are using maybe someone will look into it for you….

:+1:t2:

You’ll have to create a separate mapping with the “Sampler X Volume” action if you want the velocity to control the volume. If the MIDI note event also carries the volume, just right-click the “Play Sample X” mapping, select “Duplicate Mapping”, and change the action of the new mapping to control the volume.

I am using a regular MIDI Keyboard which sends Velocity along with the Key not volume which is a separate cc.

Yeah just duplicate the mapping as described above and you should be good.

There is no volume to select in the menu…

Sorry I forgot to mention this step: select the duplicated mapping, and in the Advanced Control Options on the bottom change the control type to “Fader / Knob”. I think this should allow you to do what you want.

not at all. I can set it to “knob” which indeed lets me select the volume, but when playing, it´s eratically doing some kind of volume change with clacking sounds.
is there any developers around?
the right way to use midi keys is to take the third parameter as velocity - no need for another mapping!

example: 0x90 0x40 0x40
means: note-on C3 0.5 (velocity of fullscale)

Try moving the volume mapping above the other one so the volume is applied before playing the sample.

(And just because the MIDI message has a volume doesn’t mean you necessarily want your samples to be volume sensitive, that’s why you need a separate mapping. Also many DJ controllers will send the volume as a separate event from the key-down message.)

I have tried changing the order. I am now using a simple iRigMini (instead of Seaboard which is sending crazy amounts of data). But still no luck. When playing a key I sometimes get a softer sound, erratically. The volume level is only full and about half - nothing in between.
I am aware, that velocity is not always wanted. 2 simple parameters in the setup could solve it: offset + multiply.
Should I do a video?