Search function invokes keyboard shortcuts while track is playing

Noticed this at the worst possible time last night - in front of an audience! Track playing with another cued, select into the search field (just my iTunes library) and started typing a t. with the next character being an alph “o” the playing track returns to the beginning. HELP! I’m using the latest update from the iTunes store of Djay Pro 2 and the latest Mac OS on my MBP.

Hi David,

we are very sorry to hear that.
Is the problem reproducible every time?

If you have any questions or suggestions, or if you would like further information, please don’t hesitate to contact us. 

Hi there,

I assume this is happening because your software went out of the search box focus.
You can prevent such action by disabling keyboard shortcuts - as stated.
In djay Pro 2 you can find the pre set “User Interface Only (Built In)” Keyboard shortcut mapping, which es the same as using the disable setting in djay Pro 1.

It would be interesting what have caused the loosing focus.
Please contact us directly when this behaviour is reoccurring.

And it’s even worse when I’m connected to my Denon MC6000MK2. Do a search and send a horrible high pitched screech through my amplified system. HELP!


Perhaps there is a way to completely turn off keyboard shortcuts?

I found a thread on the forum that said “Disable Keyboard” was added in version 1.3 but it doesn’t seem to be in version 2.

I created a blank Keyboard Shortcuts list and that seems to work. But I’m bypassing a big feature of the interface.

No, it did not go out of the search box. The only way it stops behaving this way is by using a blank keyboard shortcut list I created.