Serato DJ install messed up my Djay Pro config

I have a fully working Djay Pro setup for my Pioneer DDJ-400 and Reloop MIXON 4 connected to my 2016 MacBook Pro. On a whim, I decided to try Serato DJ, so I downloaded it and tried using my MIXON 4 controller with it. Nope, it didn’t work. Maybe it’s because I don’t have a license? Then I went back to Djay Pro and tried using my MIXON4. Djay Pro didn’t recognize it! Then I tried using my DDJ-400 with Djay Pro. Djay Pro didn’t recognize it, either! I rebooted, tried reinstalling Serato, and still failed to get my MIXON 4 working with Serato. I ended up uninstalling Serato and then went back to Djay Pro. It still didn’t recognize my MIXON 4 or DDJ-400. A couple of reboots later and I attached my DDJ-400 again and suddenly Djay Pro recognized it. I detached it, reattached my MIXON 4, and Djay Pro recognized it, too. Does anyone else have issues with having both Djay Pro and Serato DJ installed and using one of the controllers I mentioned?

yesterday i got a quite similar problem but not with serato : i own a ddj200 and i used swap between rekordbox on pc and djay on ipad. yesterday after a swap, djay didn’t want to recognize my ddj200 (connected in bluetooth)… i tried to unconnect/disconnect, to stop and start bluetooth, switch back and forth with no success… the ddj200 was recognized by my laptop (on usb) but not with djay in bluetooth… finally i resigned and today i tried again and it works…
so perhaps there’s something weird broken somewhere into djay?

The Reloop Mixon is a Serato DJ Enabled controller no purchase is necessary. I have multiple devices and use just about every DJ SW there is. No issues further than MIDI commands conflicting between alternate DJ apps when opened at the same time. Did you try configuring the setting within Djay itself when things went awry?

I did. In DJay Pro’s Devices settings, I noticed my DDJ-400 or MIXON were no longer available as options for main or pre-cue output.

I thought Serato DJ should just work with my MIXON, but Serato didn’t respond to my MIXON’s controls at all. I was using Serato DJ 2.3.5 off of their web site.