Skipping - iPad 3, Airplay, Apple TV

Love Djay! BUT using my iPad 3 with Airplay with Apple TV, I have skipping from time to time. Apple TV is hard connected to LAN, Everything is on the same wireless system.

What have I done wrong ?

Hi Warren,

Thanks for contacting us. What exactly do you mean by “skipping”? Also, which iOS and djay version do you have?

This sounds like a connection problem. And this only happens when “Mirroring” is enabled?

Do you have any other apps that support Airplay?

Interesting, so the exact same setup works with iPad Air but not with iPad 3?

We’re currently looking into this. This may be an issue that only occurs with an iPad 3.

Hiya, I’m also getting the same issue with exactly the same set up. All other apps work fine with airplay. I use it to stream TV shows so not a connection error as the video stops in the vjay app and not only the output. I tried it with iPad Air on the same network at works fine so again must be related to the app on iPad 3 and iOS 7. Please help

Sorry just to clarify I’m talking about vjay

Further info:

> Tried it with the Apple TV connected via wireless, same problem.
> Seems to only be a problem when the video is running on the TV – through Airplay mirroring – not when music only is playing.


Skipping = disc briefly stops turning on the TV screen, and the music stops for a moment, restarts, stops, starts several times. The stops are probably 1/2 second, on average, but sometime longer. They do tend to happen with several together at one time.

iOS = 7 with all updates applied.
the DJay version was current as of 2 - 3 weeks ago - I think 2.5.3, but will have to verify when I get home to the iPad!

Yes, only when mirroring is enabled, and I am displaying video on the TV of the dJay iPad screen.

I have the main router (Verizon Fios - the upgrade one) and a Netgear router configured as an access point. It shows full bars on the iPads, and on iPhones.

I have tried it with the Apple TV plugged into the LAN, and also with it on wireless. Result is the same either way.


In my situation, per your suggestion, Warren, I tried other streaming from the iPad 3 to the Apple TV, through the wireless access point, to a receiver (Pioneer Elite) HDMI, then from the receiver to the TV (also Pioneer – Kuro). I tried Amazon Prime movies, and they work fine without skipping.

Unlike Psynaptic, I am having the problem with dJay2 – fully upgraded.

Warren (the Other one ! )

Any clues on this, Warren ?