Some soundcloud tracks unavailable in playlist after upgrade from v1 to v5

Hi Folks,

Yesterday I upgraded my Djay Pro from V21 to V5.
Now some (most) of the tracks in my soundcloud playlists are showing as unavailable.

I had to upgrade to the later version as I am changing laptop and I have a gig this weekend where guests have sent me their playlists in advance so I am very keen to get this fixed.

Any idea why this is happening and what I might be able to investigate?
Kind Regards

For comparison.

screenshot from V1 running on same laptop with the same djay and soundcloud accounts.


  1. Please try logging out of SoundCloud in djay and all of your other devices including web browsers.
  2. Close djay and reboot your laptop.
  3. Temporarily disable your VPN if you are using one.
  4. Launch djay and log back into SoundCloud.

Hmm, tried that, no dice… forced a sign out on all apps
Still showing as it was.

I cant see anything different between the working tracks and the non working ones :frowning:

What has changed between v1 and v5 that might impact track availability?

That is very strange.

  1. Have you tried to Analyze Songs from the playlist dropdown menu to see if they change from grayed out? Perhaps djay is still reanalyzing your large SoundCloud library.
  2. What happens if you try to Search SoundCloud for the grayed out song and load it direct from SoundCloud instead of from the playlist?

If I search for one of the greyed out songs in Djay, then the search function doesn’t find them.
(however if I search in soundcloud it finds and plays fine)

If I search for the artist I can find the song in the search panel, but its greyed out there too…

Same search in the Djay V1 - finds the tracks fine and I can load them.

If I search for the same artist, nothing greyed out…

@Ben_Keeping are you logged into SoundCloud on both versions of djay using the same credentials (ie the same user account and password)? This feels to me like some kind of SoundCloud region restriction of the songs or something. Have you reached out to SoundCloud yet?

I’ve logged a call with soundcloud but haven’t heard back yet.

I found an article on a serato messageboard that if the creator of the track has disabled “playing with API” then that stops it playing in serato. Could it be the same thing here? (its not possible to see that setting on soundcloud to check)

Only question then would be why v1 can play the tracks but v5 not?

Hi @Ben_Keeping, I’m not sure what else to suggest here.

  1. The API could indeed be the issue as this may have changed from v1 to v5.
  2. Also, I can confirm that the support team received your request via the app so it has been logged there as well. However, we have recently launch djay Pro 5.0 for macOS and iOS so please understand that it make take some longer than expected to investigate this further. Sorry.
  3. Hopefully you get a response from SoundCloud soon. If they are able to solve this, please share your findings here in case other users experience the same problem. Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.