Spotify Error Using Mobile Data (TMobile)

I have seen comments on other threads with this issue so i thought i’d make a separate post.

There is an issue with loading spotify tracks onto the dock through T-Mobile data. I get an error message that says “Cannot connect to Spotify (8).” It’s strange because I can lookup songs but when I attempt to load them on the dock I receive the error. When connected to WiFi everything works perfectly fine. I have emailed customer support & no luck with a fix.

My app is up to date, my IOS software is up to date as well. I have an iphone 6s with T-Mobile. My spotify account is a premium account.

If anyone has figured out this bug please comment below with your tips.

Currently having this issue and I can confirm it’s TMobile problem I have 4 phones and 1 iPad Pro with Tmobile none of them work I also have a Verizon iPad Pro and it works perfectly spoke with a Tmobile tech and they escalated the complaint

I might swap to AT&T tomorrow I have way to many gigs to be waiting on Tmobile to fix this problem

might be he issue but Spotify works fine on Tmobile unfortunately Djay Pro with Spotify is blocked

Problem is it worked perfect before Tmobile had a binge option

I’m on an old unlimited Tmobile LTE plan

I paid off my iPad Pro from Tmobile and had them unlock it. I took my Tmobile iPad Pro to AT&T and activated it guess what it works perfect!!!

I submitted a ticket to Tmobile last week and their response was that it’s a Spotify issue now I can confirm it’s not it’s a Tmobile issue for sure!

It’s not a Djay or Spotify issue… it’s a t-mobile issue. It has to do with their ‘music freedom’ and the way that the t-mobile service prioritizes the data… somehow it breaks the third party spotify connection.

This is evidenced by several things:

1.Same thing happens with several other apps on the phone:

  1. On wi-fi it works perfect

  2. On a hotspot with another carrier it works fine

  3. on other carriers it works fine

I’ve contacted t-mobile several times to try to fix this and get no where.
If there was a simple way to just turn off ‘music freedom’ i’m quite certain it would fix the issue.

The other option would be Spotify allowing 3rd parties (with agreements) to use offline music. But that doesn’t seem to be changing either.

Hey guys,

merged and forked your posts to this thread in order to retain a good structure.

Anyways thank you for your post. We are aware of the issue and are gathering all user data, thank you for sharing.

Have you tried to log out of all devices in your Spotify web account, some users reported that this fixed the issue.

Lukas E.

Hi Conor,

oh ok. Have you tried the suggested steps explained below?
Also is your Spotify account still running on Premium?

Lukas E.

This reply was created from a merged topic originally titled Spotify error temp.

I’ve had this problem for over a year now and it never fixed.

Note: This conversation was created from a reply on: DJay 2 Cannot Connect to Spotify Premium.

I am not using mobile data , this is on my iPad where I can only use wifi so I still don’t know th problem


I noticed that I am also having this issue today.

I am using an iPhone 6S on T-Mobile LTE.

When I am on wifi, my DJ Pro app plays the spotify songs fine, but when I am on the LTE connection I get the error messages that are noted above.

I have went onto the spotify website and logged out of all devices, but I still receive the error messages, even after I signed out on the DJ Pro app, deleting the app, and reinstalling it. I tried my friends spotify premium credentials as well and get the same error messages.

Thanks for your help.

Are you all still working on this problem? I am experiencing this same ssue and would like to hopefully get a solution.

I am also on an unlimited plan Tmobile iphone. This issue effects not only DJay app but Serato Pyro and Pacemaker apps. Works fine over wifi just not LTE. The Music Freedom from TMobile is causing issue, I had a Tmobile tech disanle ipv4 and pinged iphone. Testing it in reverse also, neither worked. Its how musuc freedom server redirects thru 3rd party apps to connect to spotify

Just found this out the hard way at a gig. The nightclub’s WiFi went down and tried to use T-mobile cellular on my iPad and it was a no go. I had to use a hotspot from my att phone, and it started working again.

I can confirm, same thing happens to me on T-Mobile, I can’t load tracks with the DJay app. The only way I was able to make the DJay app work was by using a VPN. As soon as I disconnected the VPN, the tracks did not load.

I am definitely logged in and using my premium account. The standalone Spotify app works fine on T-Mobile.

How can we give the DJay developers the information they need to resolve this issue finally?

Hey Lukas E. –

I did some digging into this issue: there are situations where users on IPV6 addresses cannot connect to IPV4 addresses.

Until recently Spotify did not support IPV6 network connections. It had to do with Spotify’s use of Google’s Cloud Platform which only just got IPV6 address support in March 2017.

So since T-Mobile puts its users on IPV6 addresses they could not connect to Spotify’s IPV4 addresses. This IPV4 to IPV6 issue was documented and known by Spotify since 2015.

Supposedly there’s been a fix for this IPV6 issue since “Spotify iOS SDK Beta 20”.

So given that we’re DJay customers having a problem with this issue AND Apple has been starting to crack down on apps that don’t supports IPV6 properly AND this problem was supposedly fixed in an update to Spotify’s SDK, maybe the iOS DJay developers can take a look at this problem?


I don’t think Spotify with DJay Pro is “blocked” on T-Mobile. I suspect it is a technical issue with the old versions of the Spotify SDK and how it handles IPV6 connections. I haven’t seen any information that T-Mobile is blocking anything especially since no one has problems accessing Spotify using the official app while on T-Mobile.

Hopefully the DJay iOS developers can step in and give us some more information on whether it’s an IPV6 address issue or something else.

I’m open to helping test or send debugging information–please reach to me! Thanks.

This issue is definitely a problem. I DJ as well and I’m about to switch to ATT…