Static with all sound when using USB Audio Interface

Trying djay Pro for first time, which I really like. My issue is that the music sounds fine until I switch the microphone setting to use the USB audio interface. Then the music sounds staticky. If I switch back to another mic option (ex., iMac microphone), the sounds goes back to being just fine. Audio sounds fine if playing music with VLC while the interface is connected, so it seems to be an app setup issue (I’m guessing?).

Any help would be appreciated. Thanks in advance!

Setup:
Computer: iMac M1 (2021)
USB Audio Interface: Sterling UR22mkII (with latest driver installed and rebooted after installation)
Mic: Sterling ST159 (connected via XLR4 cable)

Hi @ejluecking,

Thanks for posting to the community for the first time!

So that I can better assist you could you please answer the following questions:

  1. Is the channel which your Sterling microphone is connected to clipping or providing any sort of feedback while at rest?
  2. Are you using a cloud lifter with said microphone?
  3. Does this static sound exist in applications like Garageband or Logic Pro X, or even on a video call of some sort?
  4. Have you checked to see if this could be a faulty XLR cable issue?
  5. Could you take a recording from djay with the “staticy” sounding microphone enabled and upload it to this thread?

Looking forward to hearing back from you. Have a great day!

Nathaniel,

It ends up distorting all the sound, not just the mic. In the example below, I didn’t even talk into the mic. What setting (or set up) do I have wrong?

  1. No sound issues while at rest.
  2. Not using a cloudlifter.
  3. Static sound does not exist in other apps like Garageband or TwistedWave.
  4. Given #3, I don’t believe it to be an XLR cable issue, although I don’t have another cable to try.
  5. Recording link: https://youtu.be/8dskaj2DDKA

Thank you!

Hi again,

Seeing your issue in action was incredibly helpful so thank you for the video!

Before I pass this issue along to our dev team does this glitch occur when the steps below are followed?

  1. Open djay
  2. Change the audio source to your USB interface
  3. Close djay
  4. Reopen djay and test to make sure that audio is playing correctly and through the USB interface

Happily awaiting your reply. Have a good day!

@NathanielAlgo,

You’re welcome for the video. I went through the steps as described. Upon opening again I confirmed the Mic setting was still set for the USB interface. Played a song, and it was staticky/garbled like the previous video showed. If I flipped the mic setting back to iMac microphone, the music sounds fine.

Settings in app (when problem exists):
Mixer mode: Internal
Main Output: External headphones
Pre-cueing: None
Microphone: Steinberg UR22mkII

@NathanielAlgo

Good news! I figured out the issue. I needed to set the Main Output to ALSO be the Steinberg audio interface instead of the External Headphones setting. Once I matched the mic and output settings to both be the audio interface, the garbed/static issue with the audio went away. Thank you for all your time troubleshooting this!

Hi @ejluecking,

Glad to hear it!

Looking forward to your next great post in the community!