Streaming errors with tidal

I have an iPad ios 14 and I updated to the latest versions of tidal and DJAY Pro for iPad. I’ve already matched streaming quality on both apps to normal. I’ve added cellular service to my iPad incase the issue was Wi-Fi and I still have streaming errors when loading every song. I had to keep loading and loading until it finally accepts it. I’ve already been in contact with support but they have not solved the problem I’ve Already done everything they’ve asked and I’m just trying to find a solution before I go back to using another platform in laptop. Before you ask I will not purchase tidal in my laptop after everything I have been going through with support…

Hi @Johnny_Quattlebaum,

Welcome to the Community Forums and thanks for reaching out about this. Sorry to hear about your experience with the TIDAL error message (i.e., Error Message: “Could not load track: Session does not have streaming privileges”).

I’ve just reviewed your emails with our Support Team up until this point to get up to speed on your case and what you’ve already tried. It looks like you’ve already confirmed that you have an active and valid TIDAL Premium subscription, and you’ve made sure you have a steady and stable internet connection when using TIDAL with djay.

Have you been able to check if you get the same error message when using TIDAL on either a PC or Mac with djay?

I have not because I don’t
want to pay for it.

Your case has been escalated to our Support Team Lead, and they will reach out to you directly via email to assist you with this issue on an individual basis. Thanks again for bringing it to our attention.