SX2/iPad Pro - Headphone Cue for each channel stopped working

Hi,

As usual - I plugged in the iPad, turned on SX2 and noticed the remapped pads were not assigned. Went into Midi settings and could not find my edited Midi Map. Quit DjayPro, restarted iPad, turned off/on SX2 and tried again, selected edited Midi map and all ok. BUT - the headphone cue buttons for each channel no longer give me any audio via the headphones. Tried multiple pairs of headphones/leads but no joy. Only the Master Cue works now and gives me audio levels - but that’s not helpful for mixing. any advice?

Thanks

Stretch

Hi Stretch,

Thanks for posting in our community.

This is weird… Could you please tell us:
· What version of the iPad Pro are you using?
· What version of djay are you running?
· What iPadOS version is running on your device?

What exactly did you re-map on the controller?

Hi,

iPad Pro 10.5 inch - MQDT2LL/A
iOS 14.0.1
Djay Pro 3.6.3

Roll - remapped to Autoloop
Slicer - remapped to FX & EQ kills
Sampler - remapped to NeuralMix Mute/Solo

Let me know if you need further info

Thanks

Luke

Off topic - I’ve also noticed that after triggering the NeuralMix Solo Vocal from the pad - after approx 1 bar that track will go out of time. I can film this and send a video.

I can see other people have had this problem with the SX2 from previous posts - is their a solution?

I tried using the default mapping instead of my edited map but still no headphone cue. When I press the cue buttons it triggers the specific “active monitor” midi responses. Has a recent upgrade to DjayPro or iOS caused this? Seems strange it has been working without problem since I purchased the SX2 in December until recently.

**Its definitely an iOS issue as I tested using the SX2 with Djay Pro on a MacPro and pre-cue works on all channels without problems.
**I can see there was a Djay Pro iOS update released on Feb 8th which would have been auto installed on my iPad and is the most likely cause of the issue

And all fixed now!! In Settings - Pre Cueing had an on/off switch when I plugged the iPad into the SX2 initially today. After unplugging/turning on/off everything - the Pre-Cue is now on by default in settings with no on/off switch and pre-cue to all channels is now working. That was strange - but all sorted :slight_smile:

Hi @StretchWatson, that’s good news. Thanks for letting us know.

If you have any other questions, please don’t hesitate to contact us again.