Sync of active deck disengaging after stopping Looper

  • Device model: MacBook pro M1
  • Version of operating system: 14.4.1
  • Version of djay: 5.1.6
  • Hardware/controllers used: Midi fighter twister

Summary of the issue:
After engaging the looper and stopping it, the active deck sometimes looses its sync setting. Rough estimation is that it occurs 1 out of 3 times of looper usage.

How to reproduce the issue:
After engaging the looper and stopping it, the active deck sometimes looses its sync setting. Rough estimation is that it occurs 1 out of 3 times of looper usage.

Hi @Brainbox, thanks for the details. Since this issue is repeatable, can you please try to capture a video of the issue, upload it to your Google Drive/Dropbox, enable sharing permissions, then share a link to the video here? Thanks!

Thanks! If I don’t forget, I will record my next set.

But it could also be pretty straight forward without a video? I mean, the effort to reproduce at Algo’s side would still be needed anyway? And I’m very sure it is not user error and that it is related to the looper usage. I also double-checked my midi mappings. I have this issue for some time and only after carefully looking at what happens I decided to report it. In 5.1.5 it was even worse because the decks, when stayed synced, occasionally were set to a very weird Bpm value, but that is not happening any more.

1 Like

I tried to reproduce this on my setup and could not. So, a video will be very helpful in clearly communicating your specific issue to the engineering team. Thanks!

  1. Also, can you confirm what source of music you are using (streaming services, local music stored on device, music stored on and external drive)?
  2. Are you using any Neural Mix features when this happens?

Ok, I will make the vid :slight_smile:

  1. Using beatport, off-line locker does not make a difference
  2. Yes, neural mix mapped through the EQ midi controls exclusively
  3. The looper itself is controlled by midi fighter twister controls, push for start/stop and rotate for track volume (on all 3 knobs mapped to samples from the same track), so it might be that off and volume controls come simultaneously which maybe could cause issues but cannot reproduce this way myself … (?)

Aaaand, while checking some details I can now reproduce easily, will make a vid and upload asap. Something special must be going on in this situation to make it happen every time.

  • Start Djay, there were still tracks in the queue from yesterday
  • Load tracks from the queue in deck 1 and 2
  • Enable sync on both decks
  • Start deck 1
  • Start looper, shows active sync
  • Stop looper, sync of deck 1 now entirely off

Thanks for the additional details and video @Brainbox. This is much clearer now. Do you experience the same issue with the Midi Fighter Twisters disconnected and performing the same procedure using the onscreen controls? I want to rule out the possibility of an issue with the MIDI Mapping or hardware. Thanks!

Yes, also using on-screen. And, if you after stopping the looper with the sync showing off, start the looper again, it shows active sync regardless. So the deck sync shows off but still toggles active / off while start/stop the looper. Same on midi and screen.

Okay, thanks @Brainbox. I have already forwarded this to the engineering team and they were able to replicate the issue. I’ll report back here when I have more news.

1 Like

Hi @Brainbox, I spoke with the engineering team and this is expected behavior when using the Looper. This is not a bug. The Looper is essentially another deck with always-on sync mode, so it activates the sync state on other decks. If you want Sync to remain when stopping the Looper, you need to have Deck 1 and Deck 2 playing before you stop the Looper.

I think I understand, and I can live with it.

That said, an improvement would be that after stopping the looper, it not just disengage sync, but reverts to the setting it was in just before starting the looper. But again, very low prio, there are more important things to worry about.

Thanks for the additional feedback @Brainbox