Sync still sucks, unfortunately

Good thing I can manually synch because the synch button since DJay 2 has been awful. I just don’t get why DJay can’t get it right.

More specifics? What is wrong exactly?

1 Like

One thing that is important when using Sync is to make sure that your Beat Grids are set perfectly,That’s the main difference between Djay 2 and Djay Pro.
With Djay 2 you didn’t have the ability to fine tune the Beat Grid but the Sync worked fine,
With Djay Pro however if the Beat Grid isn’t adjusted perfectly, Sync won’t Sync the tracks perfectly.

Sync works great on this end.
Just don’t use morph feature.
The team still needs to work on that.

1 Like

What is the morph feature?

Song that used to align in DJay 2 just don’t align in DJay AI . The remedy is going forward or backwards one bar.

Morph will reset the BPM TO 0% while in mixing transition.
But the 2 tracks lose sync.
The sync mode will do a great job at keeping them synced. But then the user has to reset the BPMs manually.

Find the setting in;
Automix/settings/ Tempo adjust.
To trigger this, just tap the NEXT track arrows on either side of the mixer slider.


But I’m talking about the sync button, not automix sync.

1 Like

Yes sir, I was just answering your question.

No issues with sync here, iPhone, iPad, MBP all sync perfectly well.

I might have to edit the beat grid (as @maurizio_T mentioned) to get the downbeat correct but it’s a one off thing to do and once done all is good.

So to be fair to Algoriddim, for 99% of us on here, the Sync works as it should and we’ve no complaints.

Have you tried reinstalling or resetting to defaults to make sure that something hasn’t been corrupted and is causing you problems?

Thanks for the tips, but the point is that on DJay 2 there was no need. It also depends on what music you are playing. I mainly play Rap/R&B. Changing the beat grid doesn’t mean “it works.” That’s the point. The point is getting it back to the level of DJay 2. For some reason AI can’t do it. Thanks for the tips again.

There’s actually a seperate issue with the latest update regarding Sync,
It’s actually an issue that was there last year and was fixed last December but unfortunately with the latest update it has returned…

1 Like

Yeah, it was fixed but has returned with the latest update. I peeped it.

Agreed i have the same issue

1 Like

I’ve had the issue with the Sync Button reactivating after I’ve clearly turned it off. It’s SO frustrating as the issue you’re having.