Tempo Blend randomly jumps 4 beats ahead when applied

Just tested the automix function with Tempo Blend enabled and as soon as I manually attempt to transition to the next deck, the incoming track beat jumps 4 bars ahead. I selected a playlist to work off from. Any idea why this happens?

djay Version 5.0
iPadOS 17.1.2

I just updated to the latest version and im getting this same issue. Whether in automix transition or non automix using transition arrows on laptop, the incoming track jumps.

This is not just since the update to version 5. I have been trying to solve this somehow for some time, unfortunately without success so far. But perhaps I haven’t really understood the system behind it in the settings.

I should also note that Beat Sync Interval is set to 1 beat and “auto-play when moving crossfader” is active (even though it also happens when deactivated) as well but will still skip 4 beats forward when you’re trying to sync to the nearest beat when first moving the crossfader.

The “tempo blend” sync interval is oddly set to 4 bars by default. I’m hoping they change it to what the true Beat Sync Interval is set to since this is a separate bug from my original post.

Okay, just tested tempo blend once again and now I’m not experiencing 4 bars skipping ahead. Strange…

However, the beat sync interval for tempo blend specifically still syncs to the nearest downbeat but I have it set to 1 beat.

Hi @DJ_Norm, I could not reproduce your issue with the following settings.

  1. Please make sure in Settings>General>SYNC MODE you have Beat Sync Interval set to 1 Beat
  2. Also ensure, if you are using Quantize, it is set to 1 Beat or less.

False alarm, I got it working back to normal. Not sure what the fix was. I’ll let you know if it ever happens again. @Chris_R @MrG Can you guys confirm if it’s still happening to you?

The estimated downbeat sync is still occuring however. I have the settings set to what you shown though.

Im still having the issue. Whether on automix or regular using left and right keyboard arrows it still jumps.

What I think is causing the beat jump for me is having sync on. With morph turned off it seems to play the next track in a smooth transition.

The grid is snapping to hard and makes the incoming track jump forward or back which throws it off.

Is that normal? Never had that issue before 5.0

I just changed the title of the topic since it wasn’t Automix causing it, it’s tempo blend.

@MrG have you tried adjusting your Beat Sync Interval and Quantize level as I suggested above?

I have just tried this again and everything seems to be working now. The settings mentioned above were already the same before. No idea what the problem was, maybe the last update. Anyway, thanks for the tips!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.