Tidal and DJAY not working together on MAC

Hi!

So I bought DJAY Pro and ordered Tidal Premium so that I can just easily play my sets using playlists I have online.

The problems started already from the beginning when while putting a new song in the deck, there is a pop up saying “Cannot play track. No streaming privileges.”
You have to drop down the track like 10 times for this to end. Then a couple of months ago another problem arose. Every 5th track that I’m dropping into the deck, Tidal just signs out. I have to manually sign back in, find the right playlist, the right song, and drag it back into the deck. I tried uninstalling the program and resetting everything TWICE, and what hapenned? We are back to “No streaming privileges.” again, where I need to go to Library, sign out from Tidal, sign back in and then I have to look for the song and try to make it before the previous one ends.

I am getting super frustrated, so I am switching to Serato while you deal with this. It’s a shame because I have all my cues and playlists created in DJAY, but this makes me so anxious while playing, thinking when this bug will reappear.

HELP!

Hi Ingedenize

I have been using Tidal with Djay for quite a while now with no Djay issues.

Here is the issue I had with Tidal and it is their use of the term “No steaming privileges” which’s is very misleading.

If you have a standard paid premium account (not a family account), then you can log into Tidal on multiple devices at the same time but you can only be playing One track at any one time.
If you have played another track on another device or even on your own Mac in the tidal app or in the web browser and then try to play a track on djay at the same time or shortly after stopping on another device, you can get the error message “no streaming privileges”.
Took me a while to work it out because it would have made much more sense if it had said “This account is already playing a track on another app/device”.

I’m not saying that you don’t have another tidal/djay issue but

1: make sure you are not playing a track or have just stopped playing a song (within a couple of mins) somewhere other than Djay on the same account.

2: If you are sharing your account with someone else then they are playing tracks on tidal at the same time you are trying to play a song on Djay.

3: If you are not sharing your account, then change your Tidal password in case someone else has your log in details and is using your account at the same time you are trying to use Djay :wink::wink::wink:

Hope this helps you

Ps Tidal has a number of ways of protecting itself from multiple use/misuse. If it detects a single account being used at the same time on different Ip addresses (ie different locations), it can log people out of accounts and sometimes even block them permanently.

Tidal is also sensitive to the Location it thinks you are playing in. if you are outside the USA (or other authorized country) or are using a VPN which gives it the impression you are somewhere else, it could throw up the error messages.

Heya! Thanks for the prompt reply. I am actually using a family account. Can that be a problem? Because I never actually use Tidal outside of Djay pro as I usually steam music from Spotify.

I think there is a very very good chance that this is due to multiple use of the Tidal account, whether your account is trying to stream more than the maximum allowed concurrent streams or Tidal is having issues because account users are stopping and starting tracks on multiple devices quite quickly so it’s finding it hard to keep track. If family members are turning on and off VPN’s it could also raise red flags to the system.

What was happening with me was I would be exploring new tidal content on my windows lap top and be playing snip-pits of a lot of songs, and when I found something good I would go to Djay on my IPad to add a good one to a playlist and it sometimes said “no streaming privileges”. But after waiting a certain amount of time and trying again it loaded fine. That’s how I worked out that Tidal thought I was trying to play in 2 places at the same time. In fact, sometimes it let me play load a track on djay while still streaming a track on the other device and sometimes it would give the error. I have never got that error message when only using Djay with Tidal and have never been logged out of Djay, only the web browser.

The best thing you could do is do a stress test on your djay system after logging everyone out, changing the passwords so you are the only person that can use it and see if all the problems go away. I bet they will.

As I DJ live using Tidal for occasional requests, I would never use a family account as I can’t afford to have Tidal telling me my track has no streaming privileges because everyone back at the house are streaming music and the kids have given the account details to their
friends who are also trying to steam free music :joy:

I had a similar issue with Netflix in the past where we had three users that could log in but only 2 could stream at anyone time. But because of a more sensible error message when the 3rd person tried to stream a movie we knew what the problem was immediately.

Hello again!

Thank you so much for these tips. I am completely sure that we are not using 6 devices at the same time as we are 4 family members, but maybe somehow it lags and creates this problem. I will try this ASAP, as I actually have a gig tomorrow and would love to safely use Tidal with my DJAY pro rather than try to move all my cue points to Serato for tomorrow. I will let you know how it went so that maybe somebody else with the same problem could see if it worked!

Netflix is the same for me, yes, if me, my BF and my sister are streaming at the same time, it does an error, but the error is visibly “too many devices”. This “no streaming privileges” is so misleading that I thought that its a problem with Tidal and DJAY Pro integration somehow or them not understanding that I am a paying Tidal member, not with too many devices.

Thanks again and lets see if it works!

Inga

This may seem a little drastic, but if I were in your position where you are going to use Tidal in a live situation…

I would Set up a new tidal personal account and get the free 30 day trial. Test it for 25-29 days and see if the problem is gone. You can cancel at any time without paying anything. If the family account is in your name then just use a different email address.

At least you will be sure you are the only one using the tidal account, it won’t cost anything, if the problem goes away you know why & if the problem is still there, you can move to the Mac & Djay for answers.

Hopefully someone else may have had the exact same issue as you & know the reason.
I only had the “no streaming privileges” error outside of djay. But I do think there would be quite a few posts here if people couldn’t use Tidal with Djay because of that error.