"Track not available" for all iTunes tracks

I successfully connected djay Pro with iTunes library in that way that I can see all track lists and can search from djay Pro within my iTunes library. But when I want to play a song it says “Track not available”. Within iTunes I can play all tracks without any problem. It should not be a DRM problem because I have a lot of DRM free songs and NO song can be played from within djay Pro. Connection to Spotify works without any problem.

Hi Andy, Thx for your input, unfortunately didn’t quite do it for me.

I too have the same problem. I have analyzed all tracks. I have changed the settings in iTunes as outlined here


I have changed my iTunes location back to default. I have uninstalled and reinstalled iTunes and Djay pro. I posted about this in the support forums but havent had a single reply except someone who told me to change an itunes setting that I had already changed.

Serato doesn’t have a problem with this. If it wasn’t for the spotify integration I wouldn’t even bother as djay has other issues with my controller (fx channels 3 and 4 dont work). I feel like if allgoriddum doesnt get this sorted by the time my trial expires (15 more days) I’ll have to give up and just use djay pro on my ipad with my other controller(mixon 4). I prefer the platters on my ddj-sx and was looking forward to maybe getting rid of the mixon after getting everything set up properly on the SX, but I don’t want to have to store multiple music libraries on my laptop as space is somewhat limited.

If anyone knows what I can do next I’d really appreciate it, So would algorridum as I would purchase their software if I could get it to work properly.

Guess I had to complain a bit more before my solution presented itself.

Here’s what finally worked for me. I clicked on the explorer tab below iTunes in the file browser and added my music folder, then right clicking and analyzing actually did something!

There are still some tracks that are greyed out but this is much more palatable. I’m going to experiment within itunes with some new playlists and see if I can figure out something that will get those tracks from grey to white also.

Ok here’s an update: It seems as if the remaining tracks are ones that iTunes somehow lost (probably in the midst of me moving my music directory and reinstalling iTunes) and by correcting that they became playable in Djay pro.

Now to restore everything back to its original hard drive and start all over… lol.

Hey guys,

we are sorry to hear about this. Can you tell us where you located your iTunes library?

Cheers,Lukas E.

I found a solution myself: After you connected to your iTunes library you have to “analyze” the songs. After you’ve done this you are able to play the songs.

Here is a screenshot in addition to my reply and solution. Hope that works also for the others.

“I found a solution myself: After you connected to your iTunes library you have to “analyze” the songs. After you’ve done this you are able to play the songs.”

I am getting the same error, anybody found a solution?

The files are on another hard drive on my computer. The tracks do show up but wont load.

Same issue here.My music folder is not located in the default location.

been trying to figure out how to ffix this but no luck so far