Track volume is way too loud with external mixer

Using Mac OSX and the Xone 96 mixer, the channel volumes/output are WAY too loud. So much so that I have to turn the channel volumes on the mixer down over 3 quarters of the way, which at that point, adjustment is way too fine to balance tracks well.

Either that or I have to use the channel output volumes in each channel of the DJ Pro AI, which totally defeats the purpose of having it on external.

One thing I have to say is for external mode, it would be far better if we could have only Neural Mix and to bypass everything else(EQ any audio processing internally etc.) , and having a +/- DB setting for the decks to make this really pro user friendly. The best thing in my mind is a clean audio chain.

1 Like

Yes I am having the same issue with the X:one 43c. There needs to be an option to adjust the level of the gain before it outputs to the external mixer. It is much too loud. Only workaround has been to use internal mixer, crossfader to the left and headphone to the other channel, to use the headphone as the second deck channel and adjusting the levels for headphones and master…