tracks not loading on djay for ipad

The problem I’m experiencing is with the ipad. Djay has worked without a hitch for a number of years and in the last few weeks I’ve started to experience problems. First it the ipad would get stuck on ‘Waiting for changes to be applied’ when i tried to sync it and today the tracks simply would not load to each deck. Either they’re appear to load successfully and when I went to press ‘play’ nothing would happen or Djay would simply get stuck thinking about loading the track (see attached pic). Sods law I’ve now tried it again and it’s all working fine but I’d still like to know what the problem is/was as I don’t think this will be the end of it and as someone who relies on it to provide music at wedding ceremonies etc my faith is wavering and I need it to run reliably!

Oh and itunes is saying the software is up to date and it’s running ios8.2.

I hope you can help.


Hi Ian,

Please contact our support team so we can troubleshoot this issue →

I tell a lie, the problem hasn’t gone away. The tracks appear to load to each deck but they’re not playing!

Any thoughts?..Anyone?!